<!DOCTYPE html>
<html lang="en-US">
<head>

	<meta charset="UTF-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1.0"/>

	<link rel="profile" href="http://gmpg.org/xfn/11"/>
	<link rel="pingback" href="https://www.j-14.com/xmlrpc.php"/>

	<link rel="apple-touch-icon" sizes="180x180" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/favicon/j14/apple-touch-icon.png">
	<link rel="icon" type="image/png" sizes="32x32" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/favicon/j14/favicon-32x32.png">
	<link rel="icon" type="image/png" sizes="16x16" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/favicon/j14/favicon-16x16.png">
	<link rel="mask-icon" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/favicon/j14/safari-pinned-tab.svg" color="#636363">
	<meta name="theme-color" content="#ffffff">

	
	<!-- OneTrust Cookies Consent Notice start -->
	<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-domain-script="67b11bd4-2a1a-4d74-93b2-23eb9b328575"></script>
	<script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0005,C0004,C0002,BG17" ccpa-opt-out-geo="ca" ccpa-opt-out-lspa="false"></script>
	<script type="text/javascript">
		function OptanonWrapper() {
			var allIframes = document.querySelectorAll( 'iframe[class*="optanon-category"]' );
			allIframes.forEach (function( iframe ) {
				var thisIframeCategories = iframe.classList.value.match(/C000\d+/g);

				// Check if user allowed every category assigned to this iframe
				var shouldBeLoaded = thisIframeCategories.every( function( item ) {
					return OptanonActiveGroups.match( item );
				});

				// Load iframe if every category is allowed
				if ( shouldBeLoaded ) {
					loadIframe( iframe );
				}
			});

			// load iframe element
			function loadIframe( element ) {
				if ( element.tagName.toLowerCase() == "iframe" && !element.getAttribute( "src" ) && element.dataset.src ) {
					element.setAttribute( "src", element.dataset.src );
				}
			}
		}
	</script>
	<!-- OneTrust Cookies Consent Notice end -->

	
	<script>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</script>

	<!-- Jetpack Site Verification Tags -->
<meta name="msvalidate.01" content="097DBAAF43A9B61E9E4259AA7D75B069" />
		<script>
			window.dataLayer = window.dataLayer || [];
			dataLayer = [{"pageCategory":"post","env":"prod","sponsored":"off","vupulse":"on","nodeId":219707,"contentType":"gallery","nodeCategory":"","nodeTags":["Netflix"],"contentUpdatedDate":"2020\/11\/04","contentPublishDate":"2020\/11\/04","pageTitle":"&#8216;Selena: The Series&#8217; Honors the Late Selena Quintanilla: Everything You Need to Know","sponsorshipName":"","comments":"on","author":"","sponsorship_name":"none","skimlinks":"on","zergnet":"on","audience_cat":[],"audience_subcat":[],"exclusive":"off","tragedy":"off","distroscale":"on","advertorial":"off"}];

			var site_display_format = 'desktop';

			if ( window.innerWidth < 768 ) {
				site_display_format = 'mobile';
			} else if ( window.innerWidth >= 768 && window.innerWidth <= 1024 ) {
				site_display_format = 'tablet';
			}

			dataLayer.push( { siteDisplayFormat : site_display_format } );

			var name = 'setAgeInfo';
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));

			dataLayer.push( { userAge : matches ? decodeURIComponent( matches[1] ) : '14' } );
		</script>
		
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Selena Quintanilla Netflix Series: Release Date, Cast, Spoilers</title>
	<meta name="description" content="&#039;Selena: The Series&#039; will premiere on Netflix next month and honor Mexican-American Tejano singer Selena Quintanilla. Here&#039;s what you need to know!" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Everything You Need to Know About Netflix&#039;s &#039;Selena: The Series&#039;" />
	<meta property="og:description" content="&#039;Selena: The Series&#039; will premiere on Netflix next month and honor Mexican-American Tejano singer Selena Quintanilla. Here&#039;s what you need to know!" />
	<meta property="og:url" content="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/" />
	<meta property="og:site_name" content="J-14" />
	<meta property="article:publisher" content="https://www.facebook.com/j14magazine" />
	<meta property="article:published_time" content="2020-11-04T18:39:38+00:00" />
	<meta property="article:modified_time" content="2020-11-04T18:02:09+00:00" />
	<meta property="fb:app_id" content="782474828470382" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:title" content="Everything You Need to Know About Netflix&#039;s &#039;Selena: The Series&#039;" />
	<meta name="twitter:description" content="&#039;Selena: The Series&#039; will premiere on Netflix next month and honor Mexican-American Tejano singer Selena Quintanilla. Here&#039;s what you need to know!" />
	<meta name="twitter:image" content="https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?resize=1000%2C561" />
	<meta name="twitter:creator" content="@ShelbyStivale" />
	<meta name="twitter:site" content="@J14Magazine" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"WebPage","@id":"https:\/\/www.j-14.com\/posts\/selena-quintanilla-netflix-series-release-date-cast-spoilers\/#webpage","publisher":{"@id":"https:\/\/www.j-14.com\/posts\/selena-quintanilla-netflix-series-release-date-cast-spoilers\/#organization"},"isPartOf":{"@id":"https:\/\/www.j-14.com\/posts\/selena-quintanilla-netflix-series-release-date-cast-spoilers\/#website"}}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Organization","name":"J-14","url":"https:\/\/www.j-14.com","parentOrganization":"a360 Media LLC","logo":{"@type":"ImageObject","url":"https:\/\/www.j-14.com\/wp-content\/themes\/ami-magazines\/assets\/source\/images\/icons\/logo-j14.svg"},"address":{"@type":"PostalAddress","streetAddress":"4 New York Plaza","addresslocality":"New York, NY","postalCode":"10004"},"telephone":"212-545-4800","sameAs":["https:\/\/www.facebook.com\/j14magazine","https:\/\/twitter.com\/J14Magazine","https:\/\/www.instagram.com\/j14magazine\/","https:\/\/www.pinterest.com\/j14magazine\/","http:\/\/j14magazine.tumblr.com\/"]}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","@id":"https:\/\/www.j-14.com\/posts\/selena-quintanilla-netflix-series-release-date-cast-spoilers\/#article","mainEntityOfPage":"https:\/\/www.j-14.com\/posts\/selena-quintanilla-netflix-series-release-date-cast-spoilers\/","publisher":{"@type":"Organization","name":"J-14","logo":{"@type":"ImageObject","url":"https:\/\/www.j-14.com\/wp-content\/themes\/ami-magazines\/assets\/source\/images\/icons\/logo-j14.svg"},"@id":"https:\/\/www.j-14.com\/posts\/selena-quintanilla-netflix-series-release-date-cast-spoilers\/#organization"},"headline":"&#8216;Selena: The Series&#8217; Honors the Late Selena Quintanilla: Everything You Need to Know","datePublished":"2020-11-04T13:39:38-05:00","dateModified":"2020-11-04T13:02:09-05:00","author":{"@type":"Person","name":"Shelby Stivale"},"description":"Ever since it was first announced that Netflix was gearing up to release a new series all about Mexican-American Tejano singer Selena Quintanilla,\u00a0fans were on the edge of their seats waiting for more...","articleBody":"Ever since it was first announced that Netflix was gearing up to release a new series all about Mexican-American Tejano singer Selena Quintanilla,\u00a0fans were on the edge of their seats waiting for more information. Now, the show is almost here, and\u00a0J-14\u00a0has all the details.\r\n\r\nBased on a true story, the highly anticipated series will be released 25 years after Selena's death on March 31, 1995. Previously, the\u00a0Queen of Tejano was honored in the 1997 film\u00a0Selena starring Jennifer Lopez and, once again, her story will be brought to life on fans' screens via Netflix. The official announcement for\u00a0Selena: The Series was made via the streaming service's\u00a0social media accounts on December 11, 2018. Netflix revealed that the show would \"be executive produced by The Quintanilla family.\"\r\n\r\nhttps:\/\/www.youtube.com\/watch?v=G0UIPUebDIk\r\n\r\nWhat do fans need to know about the show before it officially becomes available for streaming? Well,\u00a0J-14 broke down all the most important details. Scroll through our gallery for everything you need to know about\u00a0Selena: The Series, including its release date and a full cast list.\u00a0","isPartOf":{"@id":"https:\/\/www.j-14.com\/posts\/selena-quintanilla-netflix-series-release-date-cast-spoilers\/#webpage"},"image":["https:\/\/www.j-14.com\/wp-content\/uploads\/2020\/11\/Selena-the-series.jpeg?resize=800%2C561","https:\/\/www.j-14.com\/wp-content\/uploads\/2020\/11\/Selena-the-series.jpeg?resize=800%2C450"]}</script>
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.j-14.com/#website","url":"https://www.j-14.com/","name":"J-14","description":"","inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/#primaryimage","inLanguage":"en-US","url":"https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=1000%2C561","width":1000,"height":561,"caption":"Everything We Know About Netflix\u2019s \u2018Selena\u2019 Series"},{"@type":"WebPage","@id":"https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/#webpage","url":"https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/","name":"Selena Quintanilla Netflix Series: Release Date, Cast, Spoilers","isPartOf":{"@id":"https://www.j-14.com/#website"},"primaryImageOfPage":{"@id":"https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/#primaryimage"},"datePublished":"2020-11-04T18:39:38+00:00","dateModified":"2020-11-04T18:02:09+00:00","author":{"@id":"https://www.j-14.com/#/schema/person/0fde8b3f290d99f5c16100aa00d3b1ea"},"description":"'Selena: The Series' will premiere on Netflix next month and honor Mexican-American Tejano singer Selena Quintanilla. Here's what you need to know!","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/"]}]},{"@type":"Person","@id":"https://www.j-14.com/#/schema/person/0fde8b3f290d99f5c16100aa00d3b1ea","name":"Shelby Stivale","image":{"@type":"ImageObject","@id":"https://www.j-14.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/2b49f9d7679daea1d9668a02ebd4953b?s=96&d=mm&r=g","caption":"Shelby Stivale"},"sameAs":["https://twitter.com/ShelbyStivale"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<meta content="593583017" property="fb:admins" /><meta content="6338692612" property="fb:pages" /><link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//static.adsafeprotected.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="text/xml" title="J-14 &raquo; Feed" href="https://www.j-14.com/feed/" />
	<script>window.pb_host = "j14"</script>	<script type="text/plain" class="optanon-category-C0004" src="//acdn.adnxs.com/prebid/c/1287.j14/pb_2020_10_06_15_49_47.js" async="true"></script>
		<script>
		function gptAdsWindowWidth() {
			var w = window,
				d = document,
				e = d.documentElement,
				x = Math.max( e.scrollWidth, e.offsetWidth, e.clientWidth );
			return x;
		}

		function adsParseUrlParams( val ) {
			var result = false,
				tmp = [];
			var items = location.search.substr( 1 ).split( "&" );
			for ( var index = 0; index < items.length; index++ ) {
				tmp = items[ index ].split( "=" );
				if ( tmp[ 0 ] === val ) {
					result = decodeURIComponent( tmp[ 1 ] );
				}
			}
			return result;
		}

		function getCookie(name) {
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));
			return matches ? decodeURIComponent(matches[1]) : undefined;
		}

		function setCookie(name, value, options) {
			options = options || {};

			var expires = options.expires;

			if (typeof expires == "number" && expires) {
				var d = new Date();
				d.setTime(d.getTime() + expires * 1000);
				expires = options.expires = d;
			}
			if (expires && expires.toUTCString) {
				options.expires = expires.toUTCString();
			}

			value = encodeURIComponent(value);

			var updatedCookie = name + "=" + value;

			for (var propName in options) {
				updatedCookie += "; " + propName;
				var propValue = options[propName];
				if (propValue !== true) {
					updatedCookie += "=" + propValue;
				}
			}

			document.cookie = updatedCookie;
		}

		function amiGetCookie( name ) {
			return getCookie(name);
		}

		var googletag = googletag || {};
		var sizeMapping = [];
		window.jwVastTag = "";
		window.iasPETSlots = [];
		googletag.cmd = googletag.cmd || [];
		pbjs = window.pbjs || {que: []}; // if prebid is not already defined, define it
		googletag.slots = googletag.slots || {};
		googletag.slots_oop = googletag.slots_oop || {};
		var llSlots = llSlots || [];
		var infSlots = infSlots || [];
		var gallerySlots = gallerySlots || [];
		var initSlots = initSlots || [];
		var amazonSlots = amazonSlots || [];
		var amazonSlotsRef = amazonSlotsRef || [];
		var amazonOff = amazonOff || [];
		window.pkeys = "";
		window.ntvkeys = "";
		window.adsK = 1;

		var mobileBreakPoint = 767;
		var tabletBreakPoint = 1024;
		var inMobileViewPort = gptAdsWindowWidth() < mobileBreakPoint;
		var inTabletViewPort = tabletBreakPoint >= gptAdsWindowWidth() && gptAdsWindowWidth() > mobileBreakPoint;
		window.gptNetwork = '/4216/ami.j14/';
		var pageID = '219707';
		var keyword = 'gallery-post';
		var cType = 'Gallery';
		var adUnitZone = 'photos';

		var spons = "no";

		window.adsRefresh = {};
		window.adsRefresh.impr = [];
		window.adsRefresh.ads = [];
	</script>    	<script type="text/plain" class="optanon-category-C0004">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</script>    	<script>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</script>
		<script>
		if ( typeof amiGetCookie( 'setAgeInfo' ) === 'undefined' || amiGetCookie( 'setAgeInfo' ) > 13 ) {
			window.adsRefresh.time = 30000;
			window.refresh = true;
			window.refreshDesktop = false;
			window.refreshMobile = false;
			window.pauseRefresh = false;

			if ( (!window.refreshDesktop && window.innerWidth > 767) || (!window.refreshMobile && window.innerWidth < 768) ) {
				if ( window.refresh ) {
					googletag.cmd.push( function() {
						googletag.pubads().addEventListener( 'slotRenderEnded', function( event ) {
							var slot_id = event.slot.getSlotElementId();
							console.log( 'AMI: rendered: ', slot_id );
							if ( -1 === window.adsRefresh.not.indexOf( slot_id ) && -1 === slot_id.indexOf( 'sh-' ) ) {
								if ( event.isEmpty ) {
									window.adsRefresh.impr[slot_id] = true;
									window.adsRefresh.ads[slot_id] = setInterval( function() {
										if ( typeof window.pauseRefresh === 'undefined' || window.pauseRefresh === false ) {
											ami_gpt.refreshSlot( slot_id )
										}
									}, window.adsRefresh.time );
									if ( -1 === slot_id.indexOf( 'sh-' ) && -1 === slot_id.indexOf( 'sponsor' ) ) {
										window.dataLayer = window.dataLayer || [];
										dataLayer.push( {event: 'adsSlotEmpty', eventLabel: slot_id,} );
									}
								}
							}
						} );
						googletag.pubads().addEventListener( 'impressionViewable', function( event ) {
							var slot_id = event.slot.getSlotElementId();
							console.log( 'AMI: imr: ', slot_id );
							if ( -1 === window.adsRefresh.not.indexOf( slot_id ) && -1 === slot_id.indexOf( 'sh-' ) ) {
								console.log( 'AMI: will be refreshed: ', slot_id );
								window.adsRefresh.impr[slot_id] = true;
								window.adsRefresh.ads[slot_id] = setInterval( function() {
									if ( typeof window.pauseRefresh === 'undefined' || window.pauseRefresh === false ) {
										ami_gpt.refreshSlot( slot_id )
									}
								}, window.adsRefresh.time );
							} else {
								console.log( 'AMI: will not be refreshed: ', slot_id );
							}
						} );
					} );
				}
			}
		}
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.j-14.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.j-14.com/_static/??-eJyNjsEOwjAMQ3+ILhsakzggPgV1bdRltNnUtELj68l2hQOXyJH8bMNrNcQuVo8CTgQ8SYExLu5pIo3Z5g2kbBGbRNyo4QRKuIULcoEyYVLOJjLJBvsm3j8RLAJjpeiPyIM3c9d/8amaNdZALDBjWa2WXpsWHroIAjJmUqf8lv+GpcXXqLNkshm99X47JHHYE+7p1g1tf9EznD/1JGKT' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://www.j-14.com/wp-includes/js/jquery/jquery.js?m=1604003423g'></script>
<link rel="https://api.w.org/" href="https://www.j-14.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.j-14.com/wp-json/wp/v2/posts/219707" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.j-14.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.j-14.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.2" />
<link rel='shortlink' href='https://wp.me/pa5Rre-V9F' />
<link rel="alternate" type="application/json+oembed" href="https://www.j-14.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.j-14.com%2Fposts%2Fselena-quintanilla-netflix-series-release-date-cast-spoilers%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.j-14.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.j-14.com%2Fposts%2Fselena-quintanilla-netflix-series-release-date-cast-spoilers%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>	<script type="text/javascript">
		var onloadCallback = function () {
			grecaptcha.render('captcha_div', {
				'sitekey': '6Le3wfsSAAAAACvmSPuxMZp6mKxCn62rYP2EcJeP',
				'size': 'compact',
				'theme': 'dark'
			});
		};
	</script>
	<meta property="og:updated_time" content="2020-11-04T18:02:09+00:00" />
<meta property="og:image:secure_url" content="https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?resize=1000%2C561" />
	<script>
		window.jwVastTag = {};
		window.prerollTag = {};
		window.jwpDef = {};
		window.jwpBids = {};
	</script>
	<link rel="icon" href="https://www.j-14.com/wp-content/uploads/2020/11/android-chrome-144x144-1.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://www.j-14.com/wp-content/uploads/2020/11/android-chrome-144x144-1.png?fit=144%2C144" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.j-14.com/wp-content/uploads/2020/11/android-chrome-144x144-1.png?fit=144%2C144" />
<meta name="msapplication-TileImage" content="https://www.j-14.com/wp-content/uploads/2020/11/android-chrome-144x144-1.png?fit=144%2C144" />
			<!-- Google Tag Manager -->
			<script>( function( w, d, s, l, i ) {
					w[l] = w[l] || [];
					w[l].push( {
						'gtm.start':
							new Date().getTime(), event: 'gtm.js'
					} );
					var f = d.getElementsByTagName( s )[0],
						j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
					j.async = true;
					j.src =
						'https://www.googletagmanager.com/gtm.js?id=' + i + dl + "";
					f.parentNode.insertBefore( j, f );
				} )( window, document, 'script', 'dataLayer', "GTM-WZDVDVB");</script>		<!-- End Google Tag Manager -->
						<style type="text/css" id="wp-custom-css">
				/* Added link focus outline as per AudioEye requirements */
.ae-body a:focus, 
.ae-body a:hover, 
.ae-body a:active {
    outline: 2px solid #0074bc !important;
    outline-offset: 5px !important;
    text-decoration: none;
}			</style>
		
</head>

<body class="post-template-default single single-post postid-219707 single-format-gallery">
				<!-- Google Tag Manager (noscript) -->
			<noscript>
				<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WZDVDVB" height="0" width="0" style="display:none;visibility:hidden"></iframe>
			</noscript>		<!-- End Google Tag Manager (noscript) -->
				<div id="skin" class="dfp-slot dfp-oop"></div><div id="interstitial" class="dfp-slot dfp-oop"></div>	<div id="page-box">
		<header class="site-header">

			<div class="site-header__top mobile-hidden">
				<div class="site-header__top__inner">

                    <div class="site-header__top__left">
						                        <a href="#" id="send-scoop-trigger">Got a hot tip?</a>
                    </div>
					<div class="site-header__top__right">
						<a href="/contact">Contact Us</a> <a target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/JFT/JFT_print_digital_agecheck.jsp?cds_page_id=230176&#038;cds_mag_code=JFT">Subscribe &amp; Save!</a>
					</div>

				</div>
			</div>

			<div class="site-header__content">
				<div class="site-header__content__inner">

					<div class="site-header__content__left">
						<div class="site-header__logo">						<a href="https://www.j-14.com/" class="site__logo__link" title="Home" rel="home"> <span class="hidden-except-readers">J-14 logo</span>
							<svg class="logo">
								<use xlink:href="#logo-j14"></use>
							</svg>
						</a>
						</div>
						<div id="menu-trigger" class="site-header__menu-trigger"><span></span> <span></span> <span></span>
							<div class="hidden-except-readers">Open mobile menu button</div>
						</div>
					</div>

					<nav id="main-nav" class="site-header__main-nav">
						<div class="site-header__main-nav__inner">
							<ul id="menu-main-menu" class="site-header__main-nav__list"><li id="menu-item-98254" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98254 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/selena-gomez-63/">Selena Gomez</a></li>
<li id="menu-item-98255" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98255 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/one-direction-23/">One Direction</a></li>
<li id="menu-item-98256" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98256 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/justin-bieber-104/">Justin Bieber</a></li>
<li id="menu-item-98257" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98257 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/disney-channel-156/">Disney Channel</a></li>
<li id="menu-item-198471" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-198471 site-header__main-nav__list__item"><a href="https://www.youtube.com/channel/UCt3AGx3We2PyyNIqCoiLnxw">Must Watch Vids!</a></li>
</ul>
							<ul class="site-header__main-nav__list site-header__mobile-nav">
								<li class="site-header__main-nav__list__item">
									<a href="/newsletter">Newsletter</a>
								</li>
								<li class="site-header__main-nav__list__item">
									<a href="/contact">Contact Us</a>
								</li>
																<li class="site-header__main-nav__list__item">
									<a target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/JFT/JFT_print_digital_agecheck.jsp?cds_page_id=230176&#038;cds_mag_code=JFT">Subscribe & Save!</a>
								</li>
                                <li class="site-header__main-nav__list__item">
									<a target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/STA/eCare_Login.jsp?cds_page_id=204577&cds_mag_code=STA&id=1497454333062&lsid=71651032130027429&vid=1">Subscriber Service</a>
								</li>
							</ul>

							<a href="#" class="site-header__social-toggle">Follow us!</a>

							<ul class="site-header__social">
                                <li>
							<a href="https://www.facebook.com/j14magazine" class="site-header__social__link icon-facebook"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon"><use xlink:href="#icon-facebook"></use></svg></a>
						</li><li>
							<a href="https://twitter.com/J14Magazine" class="site-header__social__link icon-twitter"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon"><use xlink:href="#icon-twitter"></use></svg></a>
						</li><li>
							<a href="https://www.instagram.com/j14magazine/" class="site-header__social__link icon-instagram"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon"><use xlink:href="#icon-instagram"></use></svg></a>
						</li><li>
							<a href="https://www.pinterest.com/j14magazine/" class="site-header__social__link icon-pinterest"> <span class="hidden-except-readers">Social icon pinterest</span><svg class="icon"><use xlink:href="#icon-pinterest"></use></svg></a>
						</li><li>
							<a href="http://j14magazine.tumblr.com/" class="site-header__social__link icon-tumblr"> <span class="hidden-except-readers">Social icon tumblr</span><svg class="icon"><use xlink:href="#icon-tumblr"></use></svg></a>
						</li>
                                <li>
                                    <a href="/accessibility-statement/" target="_blank" class="icon-accessibility">
                                         <svg class="icon-accessibility__icon"><use xlink:href="#icon-accessibility"></use></svg>
                                    </a>
                                </li>
                            </ul>

						</div>
					</nav>

				</div>
			</div>

			<!--  Send us a scoop popup	-->
			<div class="send-scoop__container" id="send-scoop-popup">
				<div class="page-wrapper">
					<div class="send-scoop__close-btn" id="send-scoop-close"><span class="hidden-except-readers">Got a Hot tip form close button</span></div>
					<p class="send-scoop__title">Got a Hot tip?</p>
					<form id="send-scoop__form" class="send-scoop__form" novalidate="novalidate">
						<input type="hidden" name="action" value="ok_tip_form">
						<div class="sender-info">
							<div class="field-container">
								<label for="scoop-form-name" class="hidden-except-readers">Input your name</label> <input placeholder="Your Name..." type="text" name="name" value="" required="required" aria-required="true" id="scoop-form-name">
							</div>
							<div class="field-container">
								<label for="scoop-form-email" class="hidden-except-readers">Input your email</label> <input placeholder="Your email..." type="email" name="email" value="" required="required" aria-required="true" id="scoop-form-email">
							</div>
							<div class="field-container">
								<label for="scoop-form-phone" class="hidden-except-readers">Input your phone number</label> <input placeholder="Your phone number..." type="text" name="phone" value="" required="required" aria-required="true" id="scoop-form-phone">
							</div>
							<div class="sender-msg">
								<label for="scoop-message" class="hidden-except-readers">Enter scoop message here</label> <textarea placeholder="The Scoop..." name="tip" required="required" aria-required="true" id="scoop-message"></textarea>
								<div id="captcha_div"></div>
							</div>
							<button type="submit" class="send-scoop__submit" id="scoop-form-send-btn" value="scoop-form-send-btn">SEND AWAY!</button>
						</div>
					</form>
				</div>
			</div>
			<!--  // -->
		</header>

					<div class="ad-leaderboard">
								<div id="leader1" class="dfp-slot dfp-container leader1"></div>			</div>
		

<div class="popup-age">
    <div class="popup-age__content">
        <div class="popup-age__header">
            <h3 class="popup-age__title">What year were you born?</h3>
        </div>
        <div class="popup-age__body">
            <form class="popup-age__form" id="new_age_gate" method="post">
                <input class="popup-age__input-age" type="number" step="1" min="1920" max="2020" name="age_year" required>
                <input type="submit" value="Enter" class="popup-age__submit">
            </form>
        </div>
        <div class="popup-age__footer">
            <a target="_blank" rel="noopener" href="https://a360media.com/privacy-policy/">Privacy Policy</a>
        </div>
    </div>
</div>

<div class="l-container">

    
<div class="post-header">
	<h1 class="post-header__title"><span class="post-flag">All the Details</span>&#8216;Selena: The Series&#8217; Honors the Late Selena Quintanilla: Everything You Need to Know</h1>
  </div>

    <div class="l-grid">
        
<div class="l-grid__main">

	<div class="post-meta">
		<div class="post-byline">
			
<div class="post-byline__date">Nov 4, 2020 1:39 pm</div>			    <div class="post-byline__author">By <span>
            <a href="https://www.j-14.com/authors/sstivale/" title="Shelby Stivale" rel="author" class="">Shelby Stivale</a>        </span>
    </div>
    		</div>

		<span class="comment-icon"><svg><use xlink:href="#comment"></use></svg></span><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-219707" class="share-facebook sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-219707" class="share-twitter sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-219707" class="share-pinterest sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>	</div>

		<div class="gallery-header">
		<figure class="gallery-header__hero">
			<img src="https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=200%2C112" srcset="https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=200%2C112 200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=300%2C168 300w, https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=400%2C224 400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=600%2C337 600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=800%2C449 800w, https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=1000%2C561 1000w" sizes="(max-width: 1199px) 100vw, (min-width: 1200px) 1140px" alt="Everything We Know About Netflix’s ‘Selena’ Series" data-fallback-img="https://www.j-14.com/wp-content/uploads/2020/11/Selena-the-series.jpeg?fit=1000%2C561">							<p class="photo-credit">Netflix</p>
								</figure>
	</div>
			<div class="post-content">
		<p>Ever since it was first announced that Netflix was gearing up to release a new series all about Mexican-American Tejano singer <a href="https://www.instagram.com/selenaqofficial/" target="_blank" rel="noopener noreferrer"><strong>Selena Quintanilla</strong></a>, fans were on the edge of their seats waiting for more information. Now, the show is almost here, and <em>J-14 </em>has all the details.</p>
<p>Based on a true story, the highly anticipated series will be released 25 years after Selena’s death on March 31, 1995. Previously, the Queen of Tejano was honored in the 1997 film <em>Selena</em> starring Jennifer Lopez and, once again, her story will be brought to life on fans’ screens via Netflix. The official announcement for <em>Selena: The Series</em> was made via the streaming service’s <a href="https://twitter.com/netflixqueue/status/1072551738270498816?s=20" target="_blank" rel="noopener noreferrer">social media accounts</a> on December 11, 2018. Netflix revealed that the show would “be executive produced by The Quintanilla family.”</p>
<div class="ami-fluid-video-wrapper"><iframe title="Selena Gomez Talks Demi Lovato &amp; Taylor Swift Friendship | J14 Rewind" width="1180" height="664" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-src="https://www.youtube.com/embed/G0UIPUebDIk?feature=oembed" class="optanon-category-C0002-C0005"></iframe></div>
<p>What do fans need to know about the show before it officially becomes available for streaming? Well, <em>J-14</em> broke down all the most important details. <strong>Scroll through our gallery for everything you need to know about <em>Selena: The Series</em></strong><strong>, including its release date and a full cast list. </strong></p>		
<p>Love <em>J-14</em>? Be sure to <a href="https://www.youtube.com/user/j14mag?sub_confirmation=1" target="_blank">subscribe to our YouTube channel</a> for fun, exclusive videos with your favorite stars.</p>
			</div>

	
<div class="post-newsletter">
    <span class="post-newsletter__title">Don't Miss Our Newsletter!</span>
    <a class="post-newsletter__button" href="http://www.e.lifeandstylemag.com/lifestyle/lifestylesignup.action">Sign Up!</a>
</div>
	<div class="list-gallery_wrapper">
		<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"ImageGallery","description":"","image":[{"@type":"ImageObject","datePublished":"2020-11-04T13:18:55-05:00","caption":"Actress Christian Serratos will star as the late songstress. Fans may recognize the Mexican-American actress from her roles in the\u00a0Twilight\u00a0movies,\u00a0Ned's Declassified School\u00a0Survival Guide and\u00a0The Walking Dead.\u00a0In October 2020, Christian opened up about the \"pressure\" she felt to portray Selena in the show.\n\n\"I know what an important role this is and I know how important it is for all her fans and her family, so I definitely worked really hard to try and be as honestly Selena as I could,\" the actress told\u00a0Entertainment Tonight. \u201cI had never had this much responsibility before, and I just wanted to use every resource that I could. So I started working with a dialect coach on my own before I had the job, which I think was really helpful. I started working with my singing coach, who I love so much, before I booked the job and he also helped me with the audition.\u201d\n\n&nbsp;","url":"https:\/\/www.j-14.com\/wp-content\/uploads\/2020\/11\/Selena_Performance-20200123_1625_R.jpg?resize=1200%2C1200","width":"1200","height":"1200"},{"@type":"ImageObject","datePublished":"2020-11-04T13:18:55-05:00","caption":"For Selena's family, Ricardo Chavira will play as Selena\u2019s father Abraham, Gabriel Chavarria is set to appear as her brother A.B., Noemi Gonzalez as her sister Suzette, Seidy Lopez as her mother Marcella and Madison Taylor Baez as Young Selena.\n\nAs for the rest of the cast, Jesse Posey is set to portray Selena's husband Chris, Julio Macias\u00a0as Pete, Hunter Reese Pe\u00f1a will star as Ricky and Carlos Alfredo Jr. as Joe.","url":"https:\/\/www.j-14.com\/wp-content\/uploads\/2020\/11\/Selena_Pullasides-20200123_1004_R.jpg?resize=1200%2C1200","width":"1200","height":"1200"},{"@type":"ImageObject","datePublished":"2020-11-04T13:18:55-05:00","caption":"Set to be a coming-of-age story about Selena's rise to fame, the series will follow the singer as she\u00a0\"realizes her dreams.\" According to Netflix, \"she and her family make tough choices to hold on to love and music.\u201d","url":"https:\/\/www.j-14.com\/wp-content\/uploads\/2020\/11\/Selena_101-Sc01_0430_R.jpg?resize=1200%2C1200","width":"1200","height":"1200"},{"@type":"ImageObject","datePublished":"2020-11-04T13:18:55-05:00","caption":"Mark your calendars, because the show is set to premiere on December 4, 2020.","url":"https:\/\/www.j-14.com\/wp-content\/uploads\/2020\/11\/Selena_01_00_02_24_00__144164_R.jpg?resize=1200%2C1200","width":"1200","height":"1200"},{"@type":"ImageObject","datePublished":"2020-11-04T13:18:55-05:00","caption":"Each cast member opened up about what Selena means to them.\n\n\"What I find most enduring about Selena is her ability to defy boundaries. She paved the way for Latinas and inspired so many to continue in the face of adversity. I will be forever grateful for the memories she has given me, and what she has done for women like me and my daughter,\" Christian said about her starring role.\n\n&nbsp;\n\nhttps:\/\/twitter.com\/selena_netflix\/status\/1245034748528992258?s=20\n\nhttps:\/\/twitter.com\/selena_netflix\/status\/1245035655337558017?s=20\n\nhttps:\/\/twitter.com\/selena_netflix\/status\/1245036147014807553?s=20\n\n&nbsp;\n\n&nbsp;","url":"https:\/\/www.j-14.com\/wp-content\/uploads\/2020\/11\/Selena_Pullasides-20200123_1258_R.jpg?resize=1200%2C1200","width":"1200","height":"1200"}]}</script>		<div class="list-gallery">
			<div data-item-number='1' data-item-id='219716' id='219716' class='ami-image-type ami-gallery-item ami-gallery-item-0 ami-gallery-item-id-219716 ami-gallery-item-image'><p class='slide-count'>1 of 6</p><figure class="gallery-item__figure"><span class="ami-gallery-item__placeholder">
					  					<svg class="icon logo-j14">
											<use xlink:href="#logo-j14"></use>
										</svg>
									 </span><img class="loaded" src="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=200%2C289" srcset="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=200%2C289 200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=300%2C433 300w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=400%2C578 400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=600%2C867 600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=800%2C1156 800w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=1000%2C1445 1000w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=1200%2C1734 1200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=1600%2C2311 1600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=2400%2C3467 2400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=3200%2C4623 3200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=4000%2C5779 4000w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 800px" alt="Everything We Know About Netflix’s ‘Selena’ Series" data-fallback-img class="loaded"="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Performance-20200123_1625_R.jpg?fit=4480%2C6472"><p class="photo-credit">Netflix</p></figure><div class="caption-slide ">
<div class="gallery-item__caption">
<h2>Who is playing Selena Quintanilla?</h2>
<p>Actress <a href="https://www.instagram.com/kishserratos/?hl=en"><strong>Christian Serratos</strong></a> will star as the late songstress. Fans may recognize the Mexican-American actress from her roles in the <em><a href="https://www.j-14.com/tags/twilight-361/">Twilight</a> </em>movies, <a href="https://www.j-14.com/tags/ned-s-declassified-school-survival-guide-2574/"><i>Ned’s Declassified School Survival Guide</i></a> and <em>The Walking Dead</em>. In October 2020, Christian opened up about the “pressure” she felt to portray Selena in the show.</p>
<p>“I know what an important role this is and I know how important it is for all her fans and her family, so I definitely worked really hard to try and be as honestly Selena as I could,” the actress told <a href="https://www.etonline.com/christian-serratos-on-the-pressures-of-portraying-selena-quintanilla-in-netflix-series-exclusive"><em>Entertainment Tonight</em></a>. “I had never had this much responsibility before, and I just wanted to use every resource that I could. So I started working with a dialect coach on my own before I had the job, which I think was really helpful. I started working with my singing coach, who I love so much, before I booked the job and he also helped me with the audition.”</p>
<p> </p></div>
<div class="sharedaddy"><span class="comment-icon"></span>
<div class="sharedaddy sd-sharing-enabled">
<div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing">
<div class="sd-content">
<ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-219707" class="share-facebook sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li>
<li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-219707" class="share-twitter sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li>
<li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-219707" class="share-pinterest sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li>
<li class="share-end">
</ul></div>
</div>
</div>
</div>
</div></div><div data-item-number='2' data-item-id='219717' id='219717' class='ami-image-type ami-gallery-item ami-gallery-item-1 ami-gallery-item-id-219717 ami-gallery-item-image'><p class='slide-count'>2 of 6</p><figure class="gallery-item__figure"><span class="ami-gallery-item__placeholder">
					  					<svg class="icon logo-j14">
											<use xlink:href="#logo-j14"></use>
										</svg>
									 </span><img class="loaded" src="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=200%2C138" srcset="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=200%2C138 200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=300%2C208 300w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=400%2C277 400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=600%2C415 600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=800%2C554 800w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=1000%2C692 1000w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=1200%2C831 1200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=1600%2C1108 1600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=2400%2C1662 2400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=3200%2C2215 3200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=4000%2C2769 4000w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 800px" alt="Everything We Know About Netflix’s ‘Selena’ Series" data-fallback-img class="loaded"="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1004_R.jpg?fit=6354%2C4399"><p class="photo-credit">Netflix</p></figure><div class="caption-slide ">
<div class="gallery-item__caption">
<h2>Who else is starring in the series?</h2>
<p>For Selena’s family, <strong>Ricardo Chavira</strong> will play as Selena’s father Abraham, <a href="https://www.instagram.com/gabeiswitit/"><strong>Gabriel Chavarria</strong></a> is set to appear as her brother A.B., <a href="https://www.instagram.com/iamnoemigonzalez/"><strong>Noemi Gonzalez</strong></a> as her sister Suzette, <a href="https://www.instagram.com/iamseidylopez/"><strong>Seidy Lopez</strong></a> as her mother Marcella and <a href="https://www.instagram.com/madisonbaezmusic/"><strong>Madison Taylor Baez</strong></a> as Young Selena.</p>
<p>As for the rest of the cast, <a href="https://www.instagram.com/jpose13/"><strong>Jesse Posey</strong></a> is set to portray Selena’s husband Chris, <strong><a href="https://www.instagram.com/ajuliomacias/">Julio Macias</a> </strong>as Pete, <a href="https://www.instagram.com/hunterreesepena/"><strong>Hunter Reese Peña</strong></a> will star as Ricky and <a href="https://www.instagram.com/carlosalfredojr/"><strong>Carlos Alfredo Jr</strong>.</a> as Joe.</p></div>
<div class="sharedaddy"><span class="comment-icon"></span>
<div class="sharedaddy sd-sharing-enabled">
<div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing">
<div class="sd-content">
<ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-219707" class="share-facebook sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li>
<li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-219707" class="share-twitter sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li>
<li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-219707" class="share-pinterest sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li>
<li class="share-end">
</ul></div>
</div>
</div>
</div>
</div><div id="leader-inline1" class="dfp-slot dfp-container leader-inline1"></div><div id="mb1" class="dfp-slot dfp-container mb1"></div>							<script>
								if ( !inMobileViewPort ) {
									llSlots['leader-inline1'] = {id: "leader-inline1", mapping: "leader-inline"  , name: "leader-inline", device: "desktop", size: [[728, 90], [300, 250]], targeting: {pos: "leader-inline"}, correlator: true};
								}
								if ( inMobileViewPort ) {
									llSlots['mb1'] = {id: "mb1", name: "mb", device: "mobile", size: [[300, 250], [1, 1]], targeting: {pos: "mb"}, correlator: true};
								}
							</script>
							</div><div data-item-number='3' data-item-id='219718' id='219718' class='ami-image-type ami-gallery-item ami-gallery-item-2 ami-gallery-item-id-219718 ami-gallery-item-image'><p class='slide-count'>3 of 6</p><figure class="gallery-item__figure"><span class="ami-gallery-item__placeholder">
					  					<svg class="icon logo-j14">
											<use xlink:href="#logo-j14"></use>
										</svg>
									 </span><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" data-lazy="https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=200%2C289" data-srcset="https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=200%2C289 200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=300%2C433 300w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=400%2C578 400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=600%2C867 600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=800%2C1156 800w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=1000%2C1445 1000w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=1200%2C1734 1200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=1600%2C2311 1600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=2400%2C3467 2400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=3200%2C4623 3200w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 800px" alt="Everything We Know About Netflix’s ‘Selena’ Series" data-fallback-img="https://www.j-14.com/wp-content/uploads/2020/11/Selena_101-Sc01_0430_R.jpg?fit=3767%2C5442"><p class="photo-credit">Netflix</p></figure><div class="caption-slide ">
<div class="gallery-item__caption">
<h2>What will ‘Selena: The Series’ be about?</h2>
<p>Set to be a coming-of-age story about Selena’s rise to fame, the series will follow the singer as she “realizes her dreams.” According to Netflix, “she and her family make tough choices to hold on to love and music.”</p></div>
<div class="sharedaddy"><span class="comment-icon"></span>
<div class="sharedaddy sd-sharing-enabled">
<div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing">
<div class="sd-content">
<ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-219707" class="share-facebook sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li>
<li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-219707" class="share-twitter sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li>
<li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-219707" class="share-pinterest sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li>
<li class="share-end">
</ul></div>
</div>
</div>
</div>
</div></div><div data-item-number='4' data-item-id='219719' id='219719' class='ami-video-type-embed ami-gallery-item ami-gallery-item-3 ami-gallery-item-id-219719 ami-gallery-item-embed'><p class='slide-count'>4 of 6</p><div class="ami-fluid-video-wrapper"><iframe title="Selena: The Series | Official Trailer | Netflix" width="1180" height="664" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-src="https://www.youtube.com/embed/-0wz7n-h71M?feature=oembed" class="optanon-category-C0002-C0005"></iframe></div><div class="caption-slide ">
<div class="gallery-item__caption">
<h2>Is there a trailer for ‘Selena: The Series’?</h2>
<p>Yes, Netflix dropped the show’s first trailer on October 26, and gave fans a first look at the show.</p></div>
<div class="sharedaddy"><span class="comment-icon"></span>
<div class="sharedaddy sd-sharing-enabled">
<div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing">
<div class="sd-content">
<ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-219707" class="share-facebook sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li>
<li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-219707" class="share-twitter sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li>
<li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-219707" class="share-pinterest sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li>
<li class="share-end">
</ul></div>
</div>
</div>
</div>
</div><div id="leader-inline2" class="dfp-slot dfp-container leader-inline2"></div><div id="mb2" class="dfp-slot dfp-container mb2"></div>							<script>
								if ( !inMobileViewPort ) {
									llSlots['leader-inline2'] = {id: "leader-inline2", mapping: "leader-inline"  , name: "leader-inline", device: "desktop", size: [[728, 90], [300, 250]], targeting: {pos: "leader-inline"}, correlator: true};
								}
								if ( inMobileViewPort ) {
									llSlots['mb2'] = {id: "mb2", name: "mb", device: "mobile", size: [[300, 250], [1, 1]], targeting: {pos: "mb"}, correlator: true};
								}
							</script>
							<div id="sh-gal1" class="dfp-slot dfp-container sh-gal1"></div>						<script>
							llSlots['sh-gal1'] = {id: "sh-gal1", mapping: ""  , name: "sh-gal", device: "page", size: ["fluid", [2, 3]], targeting: {pos: "sh-gal", ntvPlacement: "1096420"}, correlator: true};
						</script>
						</div><div data-item-number='5' data-item-id='219720' id='219720' class='ami-image-type ami-gallery-item ami-gallery-item-4 ami-gallery-item-id-219720 ami-gallery-item-image'><p class='slide-count'>5 of 6</p><figure class="gallery-item__figure"><span class="ami-gallery-item__placeholder">
					  					<svg class="icon logo-j14">
											<use xlink:href="#logo-j14"></use>
										</svg>
									 </span><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" data-lazy="https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=200%2C138" data-srcset="https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=200%2C138 200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=300%2C208 300w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=400%2C277 400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=600%2C415 600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=800%2C554 800w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=1000%2C692 1000w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=1200%2C831 1200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=1600%2C1108 1600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=2400%2C1662 2400w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 800px" alt="Everything We Know About Netflix’s ‘Selena’ Series" data-fallback-img="https://www.j-14.com/wp-content/uploads/2020/11/Selena_01_00_02_24_00__144164_R.jpg?fit=3120%2C2160"><p class="photo-credit">Netflix</p></figure><div class="caption-slide ">
<div class="gallery-item__caption">
<h2>When will ‘Selena: The Series’ hit Netflix?</h2>
<p>Mark your calendars, because the show is set to premiere on December 4, 2020.</p></div>
<div class="sharedaddy"><span class="comment-icon"></span>
<div class="sharedaddy sd-sharing-enabled">
<div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing">
<div class="sd-content">
<ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-219707" class="share-facebook sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li>
<li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-219707" class="share-twitter sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li>
<li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-219707" class="share-pinterest sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li>
<li class="share-end">
</ul></div>
</div>
</div>
</div>
</div></div><div data-item-number='6' data-item-id='219721' id='219721' class='ami-image-type ami-gallery-item ami-gallery-item-5 ami-gallery-item-id-219721 ami-gallery-item-image'><p class='slide-count'>6 of 6</p><figure class="gallery-item__figure"><span class="ami-gallery-item__placeholder">
					  					<svg class="icon logo-j14">
											<use xlink:href="#logo-j14"></use>
										</svg>
									 </span><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs=" data-lazy="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=200%2C300" data-srcset="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=200%2C300 200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=300%2C450 300w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=400%2C600 400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=600%2C900 600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=800%2C1200 800w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=1000%2C1500 1000w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=1200%2C1800 1200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=1600%2C2400 1600w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=2400%2C3599 2400w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=3200%2C4799 3200w, https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=4000%2C5999 4000w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 800px" alt="Everything We Know About Netflix’s ‘Selena’ Series" data-fallback-img="https://www.j-14.com/wp-content/uploads/2020/11/Selena_Pullasides-20200123_1258_R.jpg?fit=4364%2C6545"><p class="photo-credit">Netflix</p></figure><div class="caption-slide ">
<div class="gallery-item__caption">
<h2>What else has the cast said about the show?</h2>
<p>Each cast member opened up about <a href="https://twitter.com/selena_netflix/status/1245030123545473026?s=20">what Selena</a> means to them.</p>
<p>“What I find most enduring about Selena is her ability to defy boundaries. She paved the way for Latinas and inspired so many to continue in the face of adversity. I will be forever grateful for the memories she has given me, and what she has done for women like me and my daughter,” Christian said about her starring role.</p>
<p> </p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">How did Selena impact your life? Let us know with <a href="https://twitter.com/hashtag/Selena25?src=hash&amp;ref_src=twsrc%5Etfw">#Selena25</a> <a href="https://t.co/6qtZzbFlyp">pic.twitter.com/6qtZzbFlyp</a></p>
<p>— Selena: The Series (@selena_netflix) <a href="https://twitter.com/selena_netflix/status/1245034748528992258?ref_src=twsrc%5Etfw">March 31, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8" type="text/plain" class="optanon-category-C0005"></script></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="und" dir="ltr">💜💜 <a href="https://t.co/LPwDrrXkIU">pic.twitter.com/LPwDrrXkIU</a></p>
<p>— Selena: The Series (@selena_netflix) <a href="https://twitter.com/selena_netflix/status/1245035655337558017?ref_src=twsrc%5Etfw">March 31, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8" type="text/plain" class="optanon-category-C0005"></script></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="und" dir="ltr">💜💜 <a href="https://t.co/6Sw3LAMESE">pic.twitter.com/6Sw3LAMESE</a></p>
<p>— Selena: The Series (@selena_netflix) <a href="https://twitter.com/selena_netflix/status/1245036147014807553?ref_src=twsrc%5Etfw">March 31, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8" type="text/plain" class="optanon-category-C0005"></script></p>
<p> </p>
<p> </p></div>
<div class="sharedaddy"><span class="comment-icon"></span>
<div class="sharedaddy sd-sharing-enabled">
<div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing">
<div class="sd-content">
<ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-219707" class="share-facebook sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li>
<li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-219707" class="share-twitter sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li>
<li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-219707" class="share-pinterest sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li>
<li class="share-end">
</ul></div>
</div>
</div>
</div>
</div><div id="leader-inline3" class="dfp-slot dfp-container leader-inline3"></div><div id="mb3" class="dfp-slot dfp-container mb3"></div>							<script>
								if ( !inMobileViewPort ) {
									llSlots['leader-inline3'] = {id: "leader-inline3", mapping: "leader-inline"  , name: "leader-inline", device: "desktop", size: [[728, 90], [300, 250]], targeting: {pos: "leader-inline"}, correlator: true};
								}
								if ( inMobileViewPort ) {
									llSlots['mb3'] = {id: "mb3", name: "mb", device: "mobile", size: [[300, 250], [1, 1]], targeting: {pos: "mb"}, correlator: true};
								}
							</script>
							</div>		</div>
	</div>

	
		<div class="post-similar">
		<h2 class="post-similar__title">More from <em>J-14</em></h2>

		<p class="post-similar__item"><a href="https://www.j-14.com/posts/netflix-november-2020-list-of-movies-tv-shows-coming-and-leaving/"><span class="post-flag">Bring on the Binging </span>All the Movies and TV Shows Coming to and Leaving Netflix in November 2020: Complete L...</a></p><p class="post-similar__item"><a href="https://www.j-14.com/posts/a-babysitters-guide-to-monster-hunting-cast-talks-set-memories/"><span class="post-flag">Exclusive </span>Netflix&#039;s &#039;A Babysitter&#039;s Guide to Monster Hunting&#039; Cast Shares Funniest On-Set Moment...</a></p><p class="post-similar__item"><a href="https://www.j-14.com/posts/jurassic-world-camp-cretaceous-cast-talks-funny-on-set-moments/"><span class="post-flag">Exclusive </span>The Cast of Netflix’s Show ‘Jurassic World: Camp Cretaceous’ Shares Funniest On-Set Mo...</a></p><p class="post-similar__item"><a href="https://www.j-14.com/posts/jurassic-world-camp-cretaceous-stars-read-texts-from-moms/"><span class="post-flag">Exclusive </span>The Cast of Netflix&#039;s Show &#039;Jurassic World: Camp Cretaceous&#039; Reads Texts From Their Mo...</a></p><p class="post-similar__item"><a href="https://www.j-14.com/posts/tall-girl-stars-ava-michelle-and-luke-eisner-do-celeb-impressions/"><span class="post-flag">Exclusive </span>Watch Netflix&#039;s &#039;Tall Girl&#039; Stars Ava Michelle and Luke Eisner Do Celeb Impressions</a></p>	</div>

	<div id="ds_default_anchor"></div>

	<div class="share-alt">
		<span class="comment-icon"><svg><use xlink:href="#comment"></use></svg></span><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-219707" class="share-facebook sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-219707" class="share-twitter sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-219707" class="share-pinterest sd-button share-icon no-text" href="https://www.j-14.com/posts/selena-quintanilla-netflix-series-release-date-cast-spoilers/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>	</div>

    <div class="ds_mb mobile-only" id="ds_mb"></div>

	<div id="comments-wrapper"><div id="spotImCommentsDiv"
     data-spotim-module="recirculation"
     data-spot-id="sp_3FZzZ6QT"
     data-post-id="219707"
     data-post-url="https://www.j-14.com/?p=219707"
     data-post-tags="Netflix">
</div></div>
	
	<div id="zergnet-widget-68224"></div>

		<div class="post-related">
		
			<div class="post-related__item">
				<a class="post-related__image" href="https://www.j-14.com/posts/netflix-november-2020-list-of-movies-tv-shows-coming-and-leaving/">
					<img src="https://www.j-14.com/wp-content/uploads/2020/10/netflix-nov-relesaed.jpg?resize=200%2C113" srcset="https://www.j-14.com/wp-content/uploads/2020/10/netflix-nov-relesaed.jpg?resize=200%2C113 200w, https://www.j-14.com/wp-content/uploads/2020/10/netflix-nov-relesaed.jpg?resize=300%2C169 300w, https://www.j-14.com/wp-content/uploads/2020/10/netflix-nov-relesaed.jpg?resize=400%2C225 400w, https://www.j-14.com/wp-content/uploads/2020/10/netflix-nov-relesaed.jpg?resize=600%2C338 600w, https://www.j-14.com/wp-content/uploads/2020/10/netflix-nov-relesaed.jpg?resize=800%2C450 800w" sizes="(max-width: 767px) 100vw, (min-width: 768px) 500px" alt="All the Movies and TV Shows Coming to and Leaving Netflix in November 2020: Complete List" data-fallback-img="https://www.j-14.com/wp-content/uploads/2020/10/netflix-nov-relesaed.jpg?fit=1000%2C561">				</a>

				<div class="post-related__title">
										<a href="https://www.j-14.com/posts/netflix-november-2020-list-of-movies-tv-shows-coming-and-leaving/"><span class="post-flag">Bring on the Binging </span>All the Movies and TV Shows Coming to and Leaving Netflix in November 2020: Complete L...</a>
				</div>
			</div>

		
			<div class="post-related__item">
				<a class="post-related__image" href="https://www.j-14.com/posts/stranger-things-season-4-release-date-cast-spoilers-more/">
					<img src="https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?resize=200%2C113" srcset="https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?resize=200%2C113 200w, https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?resize=300%2C169 300w, https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?resize=400%2C225 400w, https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?resize=600%2C338 600w, https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?resize=800%2C450 800w, https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?resize=1000%2C563 1000w, https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?resize=1200%2C675 1200w" sizes="(max-width: 767px) 100vw, (min-width: 768px) 500px" alt="Stranger Things Season 4 Details" data-fallback-img="https://www.j-14.com/wp-content/uploads/2019/12/stranger-things-season4-details-1.jpg?fit=1280%2C720">				</a>

				<div class="post-related__title">
										<a href="https://www.j-14.com/posts/stranger-things-season-4-release-date-cast-spoilers-more/"><span class="post-flag">Breaking It Down </span>Everything We Know About 'Stranger Things' Season 4: Release Date, Cast, More</a>
				</div>
			</div>

		
			<div class="post-related__item">
				<a class="post-related__image" href="https://www.j-14.com/posts/how-old-is-the-stranger-things-cast-ages-birthdays/">
					<img src="https://www.j-14.com/wp-content/uploads/2019/08/stranger-things-cast-ages.jpg?resize=200%2C113" srcset="https://www.j-14.com/wp-content/uploads/2019/08/stranger-things-cast-ages.jpg?resize=200%2C113 200w, https://www.j-14.com/wp-content/uploads/2019/08/stranger-things-cast-ages.jpg?resize=300%2C169 300w, https://www.j-14.com/wp-content/uploads/2019/08/stranger-things-cast-ages.jpg?resize=400%2C225 400w, https://www.j-14.com/wp-content/uploads/2019/08/stranger-things-cast-ages.jpg?resize=600%2C338 600w, https://www.j-14.com/wp-content/uploads/2019/08/stranger-things-cast-ages.jpg?resize=800%2C450 800w" sizes="(max-width: 767px) 100vw, (min-width: 768px) 500px" alt="Stranger Things Cast Ages" data-fallback-img="https://www.j-14.com/wp-content/uploads/2019/08/stranger-things-cast-ages.jpg?fit=1000%2C561">				</a>

				<div class="post-related__title">
										<a href="https://www.j-14.com/posts/how-old-is-the-stranger-things-cast-ages-birthdays/"><span class="post-flag">Breaking It Down </span>What Are the ‘Stranger Things’ Kids' Ages IRL? They're Way Older Than You Think</a>
				</div>
			</div>

		
			<div class="post-related__item">
				<a class="post-related__image" href="https://www.j-14.com/posts/the-princess-switch-switched-again-premiere-date-get-details/">
					<img src="https://www.j-14.com/wp-content/uploads/2020/10/princess-switch-sequel.jpeg?resize=200%2C113" srcset="https://www.j-14.com/wp-content/uploads/2020/10/princess-switch-sequel.jpeg?resize=200%2C113 200w, https://www.j-14.com/wp-content/uploads/2020/10/princess-switch-sequel.jpeg?resize=300%2C169 300w, https://www.j-14.com/wp-content/uploads/2020/10/princess-switch-sequel.jpeg?resize=400%2C225 400w, https://www.j-14.com/wp-content/uploads/2020/10/princess-switch-sequel.jpeg?resize=600%2C338 600w, https://www.j-14.com/wp-content/uploads/2020/10/princess-switch-sequel.jpeg?resize=800%2C450 800w" sizes="(max-width: 767px) 100vw, (min-width: 768px) 500px" alt="princess-switch-sequel" data-fallback-img="https://www.j-14.com/wp-content/uploads/2020/10/princess-switch-sequel.jpeg?fit=1000%2C561">				</a>

				<div class="post-related__title">
										<a href="https://www.j-14.com/posts/the-princess-switch-switched-again-premiere-date-get-details/"><span class="post-flag">Holiday Cheer </span>Vanessa Hudgens Returns in 'The Princess Switch: Switched Again': Everything to Know A...</a>
				</div>
			</div>

					</div>
</div>
        <div class="l-grid__sidebar">
	<div id="rr1" class="dfp-slot dfp-container rr1"></div>
	<div id="ds_rr_anchor"></div>

	<div id="rr2" class="dfp-slot dfp-container rr2"></div>
	
	<div class="ad-container__sticky-wrapper">
		<div class="ad-container">
			<div id="rr3" class="dfp-slot dfp-container rr3"></div>		</div>
	</div>
</div>
    </div>

</div>

<footer class="site-footer">
	<div class="site-footer__inner">
		<div class="site-footer__left">
			<a href="https://www.j-14.com/" class="site-footer__logo" title="Home" rel="home">
				<span class="hidden-except-readers">J-14 logo</span>
				<svg class="logo">
					<use xlink:href="#logo-j14-footer"></use>
				</svg>
			</a>

			<div class="site-footer__left__inner">
				<div class="site-footer__social">
					<span class="site-footer__social__heading">Follow us!</span>
					<ul class="site-footer__social__list">
						<li>
							<a href="https://www.facebook.com/j14magazine" class="site-footer__social__link icon-facebook"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon"><use xlink:href="#icon-facebook"></use></svg></a>
						</li><li>
							<a href="https://twitter.com/J14Magazine" class="site-footer__social__link icon-twitter"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon"><use xlink:href="#icon-twitter"></use></svg></a>
						</li><li>
							<a href="https://www.instagram.com/j14magazine/" class="site-footer__social__link icon-instagram"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon"><use xlink:href="#icon-instagram"></use></svg></a>
						</li><li>
							<a href="https://www.pinterest.com/j14magazine/" class="site-footer__social__link icon-pinterest"> <span class="hidden-except-readers">Social icon pinterest</span><svg class="icon"><use xlink:href="#icon-pinterest"></use></svg></a>
						</li><li>
							<a href="http://j14magazine.tumblr.com/" class="site-footer__social__link icon-tumblr"> <span class="hidden-except-readers">Social icon tumblr</span><svg class="icon"><use xlink:href="#icon-tumblr"></use></svg></a>
						</li>					</ul>
				</div>

				
				<div class="site-footer__notification">
					<p class="site-footer__notification-text">J-14 has affiliate partnerships so we may receive compensation for some links to products and services.</p>
					<p class="site-footer__notification-text">J-14 is part of the A360 Media Entertainment Group.<br>Copyright © A360 Media LLC 2020. All Rights Reserved</p>
				</div>
			</div>

		</div>

		<div class="site-footer__right">
			<div class="site-footer__menu">
				<h3 class="site-footer__heading">J-14</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-1" class="site-footer__links__list"><li id="menu-item-148584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-148584"><a href="https://www.j-14.com/archives">Archives</a></li>
<li id="menu-item-98258" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98258"><a href="https://www.j-14.com/tags/selena-gomez-63/">Selena Gomez</a></li>
<li id="menu-item-98259" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98259"><a href="https://www.j-14.com/tags/one-direction-23/">One Direction</a></li>
<li id="menu-item-98260" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98260"><a href="https://www.j-14.com/tags/justin-bieber-104/">Justin Bieber</a></li>
<li id="menu-item-98261" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98261"><a href="https://www.j-14.com/tags/disney-channel-156/">Disney Channel</a></li>
<li id="menu-item-98262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-98262"><a href="https://www.youtube.com/channel/UCt3AGx3We2PyyNIqCoiLnxw">You Tube Videos</a></li>
<li id="menu-item-121936" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-121936"><a href="https://www.j-14.com/accessibility-statement/">Accessibility Statement</a></li>
</ul></div>
									<!-- OneTrust Cookies Settings button start -->
					<a class="optanon-toggle-display" name="Manage Cookies">Manage Cookies</a>
					<!-- OneTrust Cookies Settings button end -->
							</div>

			<div class="site-footer__menu">
				<h3 class="site-footer__heading">A360 Media LLC</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-2" class="site-footer__links__list"><li id="menu-item-98263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-98263"><a href="https://a360media.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-98264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-98264"><a href="https://a360media.com/terms-and-conditions">Terms &#038; Conditions</a></li>
<li id="menu-item-98265" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98265"><a href="https://www.j-14.com/contact/">Contact Us</a></li>
<li id="menu-item-101394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101394"><a href="https://a360media.cloud.buysub.com/">Subscriber Service</a></li>
</ul></div>			</div>

			<div class="site-footer__cta">
				<div class="site-footer__cta__inner">
						<h3 class="site-footer__heading">Want more?</h3>
						<div class="textwidget custom-html-widget"><img src="https://www.j-14.com/wp-content/uploads/2018/10/j14_cover-e1539589804523.jpg" alt="In This Issue of J-14" class="img-responsive img-cover"></div>						<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/JFT/JFT_print_digital_agecheck.jsp?cds_page_id=230176&#038;cds_mag_code=JFT%20">Subscribe!</a>
						<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/JFT/JFT_Gifts_agecheck.jsp?cds_page_id=230179&#038;cds_mag_code=JFT">Give as a Gift</a>
						<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://a360media.cloud.buysub.com/">Subscriber Services</a>
				</div>
			</div>
		</div>
	</div>

</footer>
</div>
<div id="mb-sticky" class="dfp-slot dfp-container mb-sticky"></div><div id="teads" class="dfp-slot dfp-container teads"></div>	<style type="text/css" media="screen">
		@media screen and ( max-width: 782px ) {
			html {
				margin-top: 0px !important;
			}
			* html body {
				margin-top: 0px !important;
			}
			#wpadminbar {
				display: none;
			}
		}
	</style>
		<script>
		jQuery(document).ready(function ( $ ) {
			$('a[href^="http"]')
				.not('[href^="' + location.protocol + '//' + location.hostname + '"]')
				.attr('target', '_blank');
		});
	</script>
			<script id='main-js-js-extra'>
var ajaxurl = "\/wp-admin\/admin-ajax.php";
var obj = {"templateUrl":"https:\/\/www.j-14.com\/wp-content\/themes\/ami-magazines"};
</script>
<script type='text/javascript' src='https://www.j-14.com/_static/??/wp-content/mu-plugins/jetpack-9.0/_inc/build/photon/photon.min.js,/wp-content/themes/ami-magazines/assets/build/js/main.js?m=1604506372j'></script>
<script src='https://www.google.com/recaptcha/api.js?onload=onloadCallback&#038;render=explicit&#038;ver=5.5.2' id='reCaptcha-js'></script>
<script class='optanon-category-C0004' type='text/plain' src='https://static.adsafeprotected.com/vans-adapter-google-ima.js' id='ami-googleima-js'></script>
<script type='text/javascript' src='https://www.j-14.com/wp-includes/js/wp-embed.min.js?m=1604003423g'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
</script>
<script src='https://www.j-14.com/wp-content/mu-plugins/jetpack-9.0/_inc/build/sharedaddy/sharing.min.js?ver=9.0.2.1' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202045.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2.1',blog:'149160420',post:'219707',tz:'-5',srv:'www.j-14.com'} ]);
	_stq.push([ 'clickTrackerInit', '149160420', '219707' ]);
</script>
</body>
</html>
