<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
	<link rel="preload" as="image" href="/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=800%2C641&#038;quality=86&#038;strip=all" imagesrcset="/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=200%2C160&amp;quality=86&amp;strip=all 200w, /wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=300%2C240&amp;quality=86&amp;strip=all 300w, /wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=400%2C321&amp;quality=86&amp;strip=all 400w, /wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=600%2C481&amp;quality=86&amp;strip=all 600w, /wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=800%2C641&amp;quality=86&amp;strip=all 800w, /wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=1000%2C801&amp;quality=86&amp;strip=all 1000w, /wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=1200%2C962&amp;quality=86&amp;strip=all 1200w, /wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=1600%2C1282&amp;quality=86&amp;strip=all 1600w, /wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=2400%2C1923&amp;quality=86&amp;strip=all 2400w" imagesizes="(max-width: 800px) 100vw, 800px" />	<link rel="profile" href="http://gmpg.org/xfn/11"/>
	<link rel="pingback" href="https://www.j-14.com/xmlrpc.php"/>

	<link rel="apple-touch-icon" sizes="180x180" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/favicon/j14/apple-touch-icon.png">
	<link rel="icon" type="image/png" sizes="32x32" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/favicon/j14/favicon-32x32.png">
	<link rel="icon" type="image/png" sizes="16x16" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/favicon/j14/favicon-16x16.png">
	<link rel="mask-icon" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/favicon/j14/safari-pinned-tab.svg" color="#636363">
	<meta name="theme-color" content="#ffffff">

	<link rel="preload" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/fonts/RobotoSlab-Regular.woff2" as="font" type="font/woff2" crossorigin>
	<link rel="preload" href="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/fonts/Montserrat-Regular.woff2" as="font" type="font/woff2" crossorigin>

	
	<!-- OneTrust Cookies Consent Notice start -->
	<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-domain-script="67b11bd4-2a1a-4d74-93b2-23eb9b328575"></script>
	<script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0005,C0004,C0002,BG17" ccpa-opt-out-geo="ca" ccpa-opt-out-lspa="false"></script>
	<script type="text/javascript">
		function OptanonWrapper() {
			var allIframes = document.querySelectorAll( 'iframe[class*="optanon-category"]' );
			allIframes.forEach (function( iframe ) {
				var thisIframeCategories = iframe.classList.value.match(/C000\d+/g);

				// Check if user allowed every category assigned to this iframe
				var shouldBeLoaded = thisIframeCategories.every( function( item ) {
					return OptanonActiveGroups.match( item );
				});

				// Load iframe if every category is allowed
				if ( shouldBeLoaded ) {
					loadIframe( iframe );
				}
			});

			// load iframe element
			function loadIframe( element ) {
				if ( element.tagName.toLowerCase() == "iframe" && !element.getAttribute( "src" ) && element.dataset.src ) {
					element.setAttribute( "src", element.dataset.src );
				}
			}
		}
	</script>
	<!-- OneTrust Cookies Consent Notice end -->

	
	<script>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</script>
	<script type="text/plain" class="optanon-category-C0004" src="//d17tqr44y57o31.cloudfront.net/script.js"></script>
	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
		<script>
			function getCookie(name) {
				var matches = document.cookie.match(new RegExp(
						"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
				));
				return matches ? decodeURIComponent(matches[1]) : undefined;
			}

			window.dataLayer = window.dataLayer || [];
			dataLayer = [{"pageCategory":"post","env":"prod","sponsored":"off","vupulse":"on","nodeId":270930,"contentType":"article","nodeCategory":"","nodeTags":["high school musical","olivia rodrigo"],"contentUpdatedDate":"2022\/09\/14","contentPublishDate":"2022\/09\/14","pageTitle":"Goodbye! How Olivia Rodrigo Left Her Role of Nini on &#8216;High School Musical: The Musical: The Series&#8217;","sponsorshipName":"","comments":"on","author":"Shelby Stivale","skimlinks":"on","zergnet":"on","audience_cat":[],"audience_subcat":[],"exclusive":"off","tragedy":"off","distroscale":"on","advertorial":"off","branded":"off","refresh":"on"}];

			var site_display_format = 'desktop';

			if ( window.innerWidth < 768 ) {
				site_display_format = 'mobile';
			} else if ( window.innerWidth >= 768 && window.innerWidth <= 1024 ) {
				site_display_format = 'tablet';
			}

			dataLayer.push( { siteDisplayFormat : site_display_format } );

			if ( undefined !== window.cognito_user ) {
				dataLayer.push( {userName: window.cognito_user.id} );
			} else {
				let cognito_user = localStorage.getItem( 'cognito_1mhoelgmeuuf3koc56l6m6gvc4_user' );
				if ( null != cognito_user ) {
					let cognito_user_json = JSON.parse(cognito_user);
					dataLayer.push( {userName: cognito_user_json.id} );
				}
			}


			var name = 'setAgeInfo';
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));

			dataLayer.push( { userAge : matches ? decodeURIComponent( matches[1] ) : '14' } );
		</script>
		
	<!-- This site is optimized with the Yoast SEO plugin v19.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>How Did Olivia Rodrigo Leave &#039;HSMTMTS&#039;? Season 3 Nini Exit</title>
	<meta name="description" content="Olivia Rodrigo officially said goodbye to her role as Nini on &#039;High School Musical: The Musical: The Series.&#039; Details on her final scene." />
	<link rel="canonical" href="https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Saying Goodbye! How Olivia Rodrigo Left Her Role of Nini on &#039;HSMTMTS&#039;" />
	<meta property="og:description" content="Olivia Rodrigo officially said goodbye to her role as Nini on &#039;High School Musical: The Musical: The Series.&#039; Details on her final scene." />
	<meta property="og:url" content="https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/" />
	<meta property="og:site_name" content="J-14" />
	<meta property="article:publisher" content="https://www.facebook.com/j14magazine" />
	<meta property="article:published_time" content="2022-09-14T17:05:01+00:00" />
	<meta property="article:modified_time" content="2022-09-14T17:04:28+00:00" />
	<meta name="author" content="Shelby Stivale" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:title" content="Saying Goodbye! How Olivia Rodrigo Left Her Role of Nini on &#039;HSMTMTS&#039;" />
	<meta name="twitter:description" content="Olivia Rodrigo officially said goodbye to her role as Nini on &#039;High School Musical: The Musical: The Series.&#039; Details on her final scene." />
	<meta name="twitter:image" content="https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?crop=0px%2C123px%2C3000px%2C1576px&resize=1200%2C630&quality=86&strip=all" />
	<meta name="twitter:creator" content="@ShelbyStivale" />
	<meta name="twitter:site" content="@J14Magazine" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"WebPage","@id":"https:\/\/www.j-14.com\/posts\/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit\/#webpage","publisher":{"@id":"https:\/\/www.j-14.com\/posts\/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit\/#organization"},"isPartOf":{"@id":"https:\/\/www.j-14.com\/posts\/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit\/#website"}}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Organization","name":"J-14","url":"https:\/\/www.j-14.com","parentOrganization":"a360 Media LLC","logo":{"@type":"ImageObject","url":"https:\/\/www.j-14.com\/wp-content\/themes\/ami-magazines\/assets\/source\/images\/icons\/logo-j14.svg"},"address":{"@type":"PostalAddress","streetAddress":"4 New York Plaza","addresslocality":"New York, NY","postalCode":"10004"},"telephone":"212-545-4800","sameAs":["https:\/\/www.facebook.com\/j14magazine","https:\/\/twitter.com\/J14Magazine","https:\/\/www.instagram.com\/j14magazine\/","https:\/\/www.pinterest.com\/j14magazine\/","http:\/\/j14magazine.tumblr.com\/"]}</script>
<script type="application/ld+json">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</script>
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.j-14.com/#website","url":"https://www.j-14.com/","name":"J-14","description":"","inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/#primaryimage","url":"https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=3000%2C2404&quality=86&strip=all","contentUrl":"https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=3000%2C2404&quality=86&strip=all","width":3000,"height":2404,"caption":"Goodbye! How Olivia Rodrigo Left Her Role of Nini on 'High School Musical: The Musical: The Series'"},{"@type":"WebPage","@id":"https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/","url":"https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/","name":"How Did Olivia Rodrigo Leave 'HSMTMTS'? Season 3 Nini Exit","isPartOf":{"@id":"https://www.j-14.com/#website"},"primaryImageOfPage":{"@id":"https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/#primaryimage"},"datePublished":"2022-09-14T17:05:01+00:00","dateModified":"2022-09-14T17:04:28+00:00","author":{"@id":"https://www.j-14.com/#/schema/person/0fde8b3f290d99f5c16100aa00d3b1ea"},"description":"Olivia Rodrigo officially said goodbye to her role as Nini on 'High School Musical: The Musical: The Series.' Details on her final scene.","breadcrumb":{"@id":"https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/"]}]},{"@type":"BreadcrumbList","@id":"https://www.j-14.com/posts/how-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.j-14.com/"},{"@type":"ListItem","position":2,"name":"Goodbye! How Olivia Rodrigo Left Her Role of Nini on &#8216;High School Musical: The Musical: The Series&#8217;"}]},{"@type":"Person","@id":"https://www.j-14.com/#/schema/person/0fde8b3f290d99f5c16100aa00d3b1ea","name":"Shelby Stivale","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.j-14.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/40a0f26a57214989e8f89717abc8507a?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/40a0f26a57214989e8f89717abc8507a?s=96&d=mm&r=g","caption":"Shelby Stivale"},"description":"Senior Writer Shelby Stivale is a New Jersey girl at heart and loves all things TV. She often refers to herself as a reality star without the show and calls the Met Gala her Super Bowl. She's commonly found wearing cheetah print, reading a young adult novel or bragging about being an avid One Direction fan since their 2010 debut.","sameAs":["https://www.instagram.com/shelbystivale/","https://twitter.com/ShelbyStivale"],"url":"https://www.j-14.com/authors/sstivale/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<meta content="593583017" property="fb:admins" /><meta content="6338692612" property="fb:pages" /><link rel='dns-prefetch' href='//static.adsafeprotected.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="text/xml" title="J-14 &raquo; Feed" href="https://www.j-14.com/feed/" />
	<script>window.pb_host = "j14"</script>	<script type="text/plain" class="optanon-category-C0004" src="https://www.j-14.com/wp-content/client-mu-plugins/shared/includes/ami-gpt-pb-amazon/pb_2020_12_23_16_32_48.js" async="true"></script>
		<script>
		function gptAdsWindowWidth() {
			var w = window,
				d = document,
				e = d.documentElement,
				x = Math.max( e.scrollWidth, e.offsetWidth, e.clientWidth );
			return x;
		}

		function adsParseUrlParams( val ) {
			var result = false,
				tmp = [];
			var items = location.search.substr( 1 ).split( "&" );
			for ( var index = 0; index < items.length; index++ ) {
				tmp = items[ index ].split( "=" );
				if ( tmp[ 0 ] === val ) {
					result = decodeURIComponent( tmp[ 1 ] );
				}
			}
			return result;
		}

		function getCookie(name) {
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));
			return matches ? decodeURIComponent(matches[1]) : undefined;
		}

		function setCookie(name, value, options) {
			options = options || {};

			var expires = options.expires;

			if (typeof expires == "number" && expires) {
				var d = new Date();
				d.setTime(d.getTime() + expires * 1000);
				expires = options.expires = d;
			}
			if (expires && expires.toUTCString) {
				options.expires = expires.toUTCString();
			}

			value = encodeURIComponent(value);

			var updatedCookie = name + "=" + value;

			for (var propName in options) {
				updatedCookie += "; " + propName;
				var propValue = options[propName];
				if (propValue !== true) {
					updatedCookie += "=" + propValue;
				}
			}

			document.cookie = updatedCookie;
		}

		function amiGetCookie( name ) {
			return getCookie(name);
		}

		var googletag = googletag || {};
		var sizeMapping = [];
		window.jwVastTag = "";
		window.iasPETSlots = [];
		googletag.cmd = googletag.cmd || [];
		pbjs = window.pbjs || {que: []}; // if prebid is not already defined, define it
		googletag.slots = googletag.slots || {};
		googletag.slots_oop = googletag.slots_oop || {};
		var llSlots = llSlots || [];
		var infSlots = infSlots || [];
		var gallerySlots = gallerySlots || [];
		var initSlots = initSlots || [];
		var amazonSlots = amazonSlots || [];
		var amazonSlotsRef = amazonSlotsRef || [];
		var amazonOff = amazonOff || [];
		window.pkeys = "";
		window.ntvkeys = "";
		window.adsK = 1;

		var mobileBreakPoint = 767;
		var tabletBreakPoint = 1024;
		var inMobileViewPort = gptAdsWindowWidth() < mobileBreakPoint;
		var inTabletViewPort = tabletBreakPoint >= gptAdsWindowWidth() && gptAdsWindowWidth() > mobileBreakPoint;
		window.gptNetwork = '/4216/ami.j14/';
		var pageID = '270930';
		var keyword = 'post';
		var cType = 'Article';
		var adUnitZone = 'news';

		var spons = "no";

		window.adsRefresh = {};
		window.adsRefresh.impr = [];
		window.adsRefresh.ads = [];
	</script>    	<script type="text/plain" class="optanon-category-C0004">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</script>    	<script>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</script>
		<script>
		if ( typeof amiGetCookie( 'setAgeInfo' ) === 'undefined' || amiGetCookie( 'setAgeInfo' ) > 13 ) {
			window.adsRefresh.time = 30000;
			window.refresh = true;
			window.refreshDesktop = false;
			window.refreshMobile = false;
			window.pauseRefresh = false;

			if ( (!window.refreshDesktop && window.innerWidth > 767) || (!window.refreshMobile && window.innerWidth < 768) ) {
				if ( window.refresh ) {
					googletag.cmd.push( function() {
						googletag.pubads().addEventListener( 'slotRenderEnded', function( event ) {
							var slot_id = event.slot.getSlotElementId();
							console.log( 'AMI: rendered: ', slot_id );
							if ( -1 === window.adsRefresh.not.indexOf( slot_id ) && -1 === slot_id.indexOf( 'sh-' ) ) {
								if ( event.isEmpty ) {
									window.adsRefresh.impr[slot_id] = true;
									window.adsRefresh.ads[slot_id] = setInterval( function() {
										if ( typeof window.pauseRefresh === 'undefined' || window.pauseRefresh === false ) {
											ami_gpt.refreshSlot( slot_id )
										}
									}, window.adsRefresh.time );
									if ( -1 === slot_id.indexOf( 'sh-' ) && -1 === slot_id.indexOf( 'sponsor' ) ) {
										window.dataLayer = window.dataLayer || [];
										dataLayer.push( {event: 'adsSlotEmpty', eventLabel: slot_id,} );
									}
								}
							}
						} );
						googletag.pubads().addEventListener( 'impressionViewable', function( event ) {
							var slot_id = event.slot.getSlotElementId();
							console.log( 'AMI: imr: ', slot_id );
							if ( -1 === window.adsRefresh.not.indexOf( slot_id ) && -1 === slot_id.indexOf( 'sh-' ) ) {
								console.log( 'AMI: will be refreshed: ', slot_id );
								window.adsRefresh.impr[slot_id] = true;
								window.adsRefresh.ads[slot_id] = setInterval( function() {
									if ( typeof window.pauseRefresh === 'undefined' || window.pauseRefresh === false ) {
										ami_gpt.refreshSlot( slot_id )
									}
								}, window.adsRefresh.time );
							} else {
								console.log( 'AMI: will not be refreshed: ', slot_id );
							}
						} );
					} );
				}
			}
		}
	</script>
	<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.j-14.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.j-14.com/_static/??-eJx9jdsKwjAQRH/IdLVi8UX8lrhZanRzIbNF+vcGQbAvPp4Zzgy9qouZdQkCeoCShOhFJUm2DVT1qzSnMntehxTzwMCO/um9++WNxCXb52JxVZc5ZhDEN76TqIdFrk0AChFG3aHWY5PgaoHB3bTw08FWFXxnr+lymKbj/jxO4+kNkvBQNQ==' type='text/css' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://www.j-14.com/_static/??/wp-content/themes/ami-magazines/assets/build/css/style-j14.css,/wp-content/mu-plugins/jetpack-11.3/_inc/genericons/genericons/genericons.css?m=1663082622' type='text/css' media='all' />
<script type="text/javascript" src="https://www.j-14.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZmZG5kaWhiWkWAK+KIiM=" ></script><link rel="https://api.w.org/" href="https://www.j-14.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.j-14.com/wp-json/wp/v2/posts/270930" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.j-14.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.j-14.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.2" />
<link rel='shortlink' href='https://www.j-14.com/?p=270930' />
<link rel="alternate" type="application/json+oembed" href="https://www.j-14.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.j-14.com%2Fposts%2Fhow-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.j-14.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.j-14.com%2Fposts%2Fhow-did-olivia-rodrigo-leave-hsmtmts-season-3-nini-exit%2F&#038;format=xml" />
<style>img#wpstats{display:none}</style>
			<script type="text/plain" class="optanon-category-C0004" async src="https://ovp.iris.tv/libs/context/iris-context.min.js"></script>
		<script>
			var irisToken = decodeURIComponent( "VK00Q6P7F28YEQ6" );
			// Initialize Iris Context API
			window.addEventListener('IrisContextAPI', function() {
				window.irisContext = window.IrisContextAPI({
					client_token: irisToken,
				});
			});
		</script>
			<script type="text/plain" class="optanon-category-C0004" async src="//js-sec.indexww.com/ht/p/183518-190707627379353.js"></script>
	<script>
		var headertag = headertag || {};
		headertag.cmd = headertag.cmd || [];
	</script>
	<meta property="og:updated_time" content="2022-09-14T17:04:28+00:00" />
<meta property="og:image" content="https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?crop=0px%2C123px%2C3000px%2C1576px&#038;resize=1200%2C630&#038;quality=86&#038;strip=all" />
<meta property="og:image:secure_url" content="https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?crop=0px%2C123px%2C3000px%2C1576px&#038;resize=1200%2C630&#038;quality=86&#038;strip=all" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
	<script>
		/**
		 * Will resolve when amazon is loaded on DOM
		 * * @return {Promise}
		 */
		const waitForAmazon = new Promise((resolve, reject) => {
			amzn_check(resolve, 100, 50 );
			setTimeout(resolve, 5000);
		});

		function amzn_check(resolve, interval, retriesLeft) {
			if ( typeof window.apstag == 'object' && window.apstag ) {
				console.log( 'AMI jwp - Amazon loaded' );
				return resolve();
			}

			if ( --retriesLeft > 0 ) {
				if ( typeof window.apstag != 'object' && !window.apstag ) {
					setTimeout( function(){ amzn_check( resolve, interval, retriesLeft ); }, interval );
					console.log( 'AMI jwp Amazon not loaded ' );
				}
			} else {
				console.log( 'AMI jwp No Retries left - Amazon not loaded' );
				return resolve();
			}
		}


		window.jwVastTag = {};
		window.prerollTag = {};
		window.jwpDef = {};
		window.jwpBids = {};
	</script>
	<link rel="icon" href="https://www.j-14.com/wp-content/uploads/2020/11/android-chrome-144x144-1.png?fit=32%2C32&#038;quality=86&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://www.j-14.com/wp-content/uploads/2020/11/android-chrome-144x144-1.png?fit=144%2C144&#038;quality=86&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.j-14.com/wp-content/uploads/2020/11/android-chrome-144x144-1.png?fit=144%2C144&#038;quality=86&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://www.j-14.com/wp-content/uploads/2020/11/android-chrome-144x144-1.png?fit=144%2C144&#038;quality=86&#038;strip=all" />
			<!-- Google Tag Manager -->
			<script>( function( w, d, s, l, i ) {
					w[l] = w[l] || [];
					w[l].push( {
						'gtm.start':
							new Date().getTime(), event: 'gtm.js'
					} );
					var f = d.getElementsByTagName( s )[0],
						j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
					j.async = true;
					j.src =
						'https://www.googletagmanager.com/gtm.js?id=' + i + dl + "";
					f.parentNode.insertBefore( j, f );
				} )( window, document, 'script', 'dataLayer', "GTM-WZDVDVB");</script>		<!-- End Google Tag Manager -->
				<script>
		var gtm_lock = setTimeout( function() {
			if ( "undefined" === typeof OnetrustActiveGroups || OnetrustActiveGroups.indexOf( ',C0002,' ) || OnetrustActiveGroups.indexOf( ',C0003,' ) || OnetrustActiveGroups.indexOf( ',C0004,' ) ) {
				window.dataLayer = window.dataLayer || [];
				dataLayer.push( {event: 'delayed_load'} );
			}
		}, 5000 );

		window.addEventListener( 'load', function( event ) {
			if ( "undefined" === typeof OnetrustActiveGroups || OnetrustActiveGroups.indexOf( ',C0002,' ) || OnetrustActiveGroups.indexOf( ',C0003,' ) || OnetrustActiveGroups.indexOf( ',C0004,' ) ) {
				window.dataLayer = window.dataLayer || [];
				dataLayer.push( {event: 'delayed_load'} );
				clearTimeout( gtm_lock );
			}
		} );

	</script>
			<style type="text/css" id="wp-custom-css">
			/* Added link focus outline as per AudioEye requirements */
.ae-body a:focus, 
.ae-body a:hover, 
.ae-body a:active {
    outline: 2px solid #0074bc !important;
    outline-offset: 5px !important;
    text-decoration: none;
}		</style>
		
</head>

<body class="post-template-default single single-post postid-270930 single-format-standard">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>			<!-- Google Tag Manager (noscript) -->
			<noscript>
				<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WZDVDVB" height="0" width="0" style="display:none;visibility:hidden"></iframe>
			</noscript>		<!-- End Google Tag Manager (noscript) -->
				<div id="skin" class="dfp-slot dfp-oop"></div><div id="interstitial" class="dfp-slot dfp-oop"></div>	<div id="page-box">
		<header class="site-header">

			<div class="site-header__top mobile-hidden">
				<div class="site-header__top__inner">

                    <div class="site-header__top__left">
						                        <a href="#" id="send-scoop-trigger">Got a hot tip?</a>
                    </div>
					<div class="site-header__top__right">
						<a href="/contact">Contact Us</a> <a target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/JFT/JFT_print_digital_agecheck.jsp?cds_page_id=230176&#038;cds_mag_code=JFT">Subscribe &amp; Save!</a>
					</div>

				</div>
			</div>

			<div class="site-header__content">
				<div class="site-header__content__inner">

					<div class="site-header__content__left">
						<div class="site-header__logo">						<a href="https://www.j-14.com/" class="site__logo__link" title="Home" rel="home"> <span class="hidden-except-readers">J-14 logo</span>
							<svg class="logo">
								<use xlink:href="#logo-j14"></use>
							</svg>
						</a>
						</div>
						<div class="login-and-mobile-nav">
							<div class="header-mylo__mobile mobile-only">
								<a class="mylo-signin__mobile" href="https://www.mylo.id/login?client_id=25u4cv7suvrfjrjr22rf8jccq1&#038;redirect_uri=https://www.j-14.com/auth/login" target="_self">
									<span>Login</span>
								</a>
							</div>
							<div id="menu-trigger" class="site-header__menu-trigger"><span></span> <span></span> <span></span>
								<div class="hidden-except-readers">Open mobile menu button</div>
							</div>
						</div>
					</div>

					<nav id="main-nav" class="site-header__main-nav">
						<div class="site-header__main-nav__inner">
							<ul id="menu-main-menu" class="site-header__main-nav__list"><li id="menu-item-257933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-257933 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/harry-styles-118/">Harry Styles</a></li>
<li id="menu-item-257934" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-257934 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/zendaya-188/">Zendaya</a></li>
<li id="menu-item-257935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-257935 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/olivia-rodrigo-36165/">Olivia Rodrigo</a></li>
<li id="menu-item-257936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-257936 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/jojo-siwa-24638/">JoJo Siwa</a></li>
<li id="menu-item-257937" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-257937 site-header__main-nav__list__item"><a href="https://www.j-14.com/tags/dixie-damelio/">Dixie D&#8217;Amelio</a></li>
</ul>
							<ul class="site-header__main-nav__list site-header__mobile-nav">
								<li class="site-header__main-nav__list__item">
									<a href="/newsletter">Newsletter</a>
								</li>
								<li class="site-header__main-nav__list__item">
									<a href="/contact">Contact Us</a>
								</li>
																<li class="site-header__main-nav__list__item">
									<a target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/JFT/JFT_print_digital_agecheck.jsp?cds_page_id=230176&#038;cds_mag_code=JFT">Subscribe & Save!</a>
								</li>
                                <li class="site-header__main-nav__list__item">
									<a target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/STA/eCare_Login.jsp?cds_page_id=204577&cds_mag_code=STA&id=1497454333062&lsid=71651032130027429&vid=1">Subscriber Service</a>
								</li>
							</ul>

							<div class="login-and-socials">
								<div class="header-mylo">
									<a class="header-mylo__signin" href="https://www.mylo.id/login?client_id=25u4cv7suvrfjrjr22rf8jccq1&#038;redirect_uri=https://www.j-14.com/auth/login" target="_self">
										<svg class="header-mylo__signin-icon"><use xlink:href="#icon-signin"></use></svg>
										<span>Login</span>
									</a>
								</div>

								<a href="#" class="site-header__social-toggle">Follow us!</a>
							</div>

							<ul class="site-header__social">
                                <li>
							<a href="https://www.facebook.com/j14magazine" class="site-header__social__link icon-facebook"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon"><use xlink:href="#icon-facebook"></use></svg></a>
						</li><li>
							<a href="https://twitter.com/J14Magazine" class="site-header__social__link icon-twitter"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon"><use xlink:href="#icon-twitter"></use></svg></a>
						</li><li>
							<a href="https://www.instagram.com/j14magazine/" class="site-header__social__link icon-instagram"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon"><use xlink:href="#icon-instagram"></use></svg></a>
						</li><li>
							<a href="https://www.pinterest.com/j14magazine/" class="site-header__social__link icon-pinterest"> <span class="hidden-except-readers">Social icon pinterest</span><svg class="icon"><use xlink:href="#icon-pinterest"></use></svg></a>
						</li><li>
							<a href="http://j14magazine.tumblr.com/" class="site-header__social__link icon-tumblr"> <span class="hidden-except-readers">Social icon tumblr</span><svg class="icon"><use xlink:href="#icon-tumblr"></use></svg></a>
						</li>
                                <li>
                                    <a href="/accessibility-statement/" target="_blank" class="icon-accessibility" aria-label="Accessibility Statement">
										<svg class="icon-accessibility__icon" aria-hidden="true"><use xlink:href="#icon-accessibility"></use></svg>
										<span class="hidden-except-readers">Accessibility statement</span>
									</a>
                                </li>
                            </ul>
						</div>
					</nav>

				</div>
			</div>

			<!--  Send us a scoop popup	-->
			<div class="send-scoop__container" id="send-scoop-popup">
				<div class="page-wrapper">
					<div class="send-scoop__close-btn" id="send-scoop-close" tabindex="0"><span class="hidden-except-readers">Got a Hot tip form close button</span></div>
					<p class="send-scoop__title">Got a Hot tip?</p>
					<form id="send-scoop__form" class="send-scoop__form" novalidate="novalidate">
						<input type="hidden" name="action" value="ok_tip_form">
						<div class="sender-info">
							<div class="field-container">
								<label for="scoop-form-name" class="hidden-except-readers">Input your name</label> <input placeholder="Your Name..." type="text" name="name" value="" required="required" aria-required="true" id="scoop-form-name">
							</div>
							<div class="field-container">
								<label for="scoop-form-email" class="hidden-except-readers">Input your email</label> <input placeholder="Your email..." type="email" name="email" value="" required="required" aria-required="true" id="scoop-form-email">
							</div>
							<div class="field-container">
								<label for="scoop-form-phone" class="hidden-except-readers">Input your phone number</label> <input placeholder="Your phone number..." type="text" name="phone" value="" required="required" aria-required="true" id="scoop-form-phone">
							</div>
							<div class="sender-msg">
								<label for="scoop-message" class="hidden-except-readers">Enter scoop message here</label> <textarea placeholder="The Scoop..." name="tip" required="required" aria-required="true" id="scoop-message"></textarea>
							</div>
							<button type="submit" class="send-scoop__submit" id="scoop-form-send-btn" value="scoop-form-send-btn">SEND AWAY!</button>
						</div>
					</form>
				</div>
			</div>
			<!--  // -->
		</header>

					<div class="ad-leaderboard">
								<div id="leader1" class="dfp-slot dfp-container leader1 mobile-hidden"></div>				<div id="blockbuster" class="dfp-slot dfp-container blockbuster "></div>			</div>
		

<div class="popup-age">
    <div class="popup-age__content">
        <div class="popup-age__header">
            <h3 class="popup-age__title">What year were you born?</h3>
        </div>
        <div class="popup-age__body">
            <form class="popup-age__form" id="new_age_gate" method="post">
                <input class="popup-age__input-age" type="number" step="1" min="1920" max="2022" name="age_year" required aria-label="Age input" aria-required="true">
                <input type="submit" value="Enter" class="popup-age__submit" aria-label="Age submit">
            </form>
        </div>
        <div class="popup-age__footer">
            <a target="_blank" rel="noopener" href="https://a360media.com/privacy-policy/">Privacy Policy</a>
        </div>
    </div>
</div>

<div class="l-container">

    
<div class="post-header">
	<h1 class="post-header__title"><span class="post-flag">OMG</span>Goodbye! How Olivia Rodrigo Left Her Role of Nini on &#8216;High School Musical: The Musical: The Series&#8217;</h1>
  </div>

    <div class="l-grid">
        
<div class="l-grid__main">

    <div class="post-meta">
        <div class="post-byline">
            
<div class="post-byline__date">Sep 14, 2022 1:05 pm</div>                <div class="post-byline__author">By <span>
            <a href="https://www.j-14.com/authors/sstivale/" title="Shelby Stivale" rel="author" class="">Shelby Stivale</a>        </span>
    </div>
            </div>

            </div>

            <figure class="post-hero">
            <div style="padding-bottom:80.125%;" class="ratio-based-placeholder"><img src="https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=800%2C641&#038;quality=86&#038;strip=all" srcset="https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=200%2C160&amp;quality=86&amp;strip=all 200w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=300%2C240&amp;quality=86&amp;strip=all 300w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=400%2C321&amp;quality=86&amp;strip=all 400w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=600%2C481&amp;quality=86&amp;strip=all 600w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=800%2C641&amp;quality=86&amp;strip=all 800w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=1000%2C801&amp;quality=86&amp;strip=all 1000w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=1200%2C962&amp;quality=86&amp;strip=all 1200w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=1600%2C1282&amp;quality=86&amp;strip=all 1600w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=2400%2C1923&amp;quality=86&amp;strip=all 2400w" sizes="(max-width: 800px) 100vw, 800px" alt="Goodbye! How Olivia Rodrigo Left Her Role of Nini on &#039;High School Musical: The Musical: The Series&#039;" data-fallback-img="https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts01.jpeg?fit=3000%2C2404&#038;quality=86&#038;strip=all" width="800" height="641"></div>
                            <p class="photo-credit">Disney/Anne Marie Fox</p>
                    </figure>
        
	<div id="mb1" class="dfp-slot dfp-container mb1 "></div>	<div id="leader-inline1" class="dfp-slot dfp-container leader-inline1 "></div>
    <div class="post-content track-ga">
        <p>Saying goodbye! <a href="https://www.j-14.com/tags/olivia-rodrigo-36165/"><strong>Olivia Rodrigo</strong></a> officially <a href="https://www.j-14.com/posts/will-olivia-rodrigo-star-in-hsmtmts-season-3-what-we-know/">left her role as Nini</a> during the <a href="https://www.j-14.com/tags/high-school-musical-917/"><em>High School Musical: The Musical: The Series</em></a> season 3 finale.</p>
<p>“This season it’s about trying to give her character a proper sendoff while also leaving room for other characters to really step into the fray and step into the spotlight,” showrunner <a href="https://www.j-14.com/posts/high-school-musical-the-musical-the-series-season-2/"><strong>Tim Federle</strong></a> told <a href="https://www.etonline.com/hsmtmts-boss-teases-season-3-and-olivia-rodrigos-sendoff-exclusive-187384" target="_blank" rel="noopener" aria-describedby="audioeye_new_window_message"><em>Entertainment Tonight</em></a> in July 2022. “Personally, it’s a joy to see <a href="https://www.j-14.com/posts/is-olivia-rodrigo-making-more-music-details-on-album-no-2/">Olivia’s music explode</a> in such a big way. It was so fun to have her back and reminisce on the beginning.”</p>
<p><strong>Keep reading for more details on how she left the show. </strong></p>
<div class="link-related link-related__with-thumb">
	<a href="https://www.j-14.com/posts/will-high-school-musical-4-happen-cast-talks-another-movie/" target="_blank" data-track-category="Article Page" data-track-action="Tap Interstitial Link" data-track-label="https://www.j-14.com/posts/will-high-school-musical-4-happen-cast-talks-another-movie/" class="link-related__link">
					<span class="link-related__image">
				<div style="padding-bottom:56%;" class="ratio-based-placeholder"><img src="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.j-14.com/wp-content/uploads/2021/01/hsm4-pp.jpg?fit=200%2C112&amp;quality=86&amp;strip=all" data-srcset="https://www.j-14.com/wp-content/uploads/2021/01/hsm4-pp.jpg?fit=200%2C112&amp;quality=86&amp;strip=all 200w, https://www.j-14.com/wp-content/uploads/2021/01/hsm4-pp.jpg?fit=300%2C168&amp;quality=86&amp;strip=all 300w, https://www.j-14.com/wp-content/uploads/2021/01/hsm4-pp.jpg?fit=400%2C224&amp;quality=86&amp;strip=all 400w, https://www.j-14.com/wp-content/uploads/2021/01/hsm4-pp.jpg?fit=600%2C337&amp;quality=86&amp;strip=all 600w, https://www.j-14.com/wp-content/uploads/2021/01/hsm4-pp.jpg?fit=800%2C449&amp;quality=86&amp;strip=all 800w, https://www.j-14.com/wp-content/uploads/2021/01/hsm4-pp.jpg?fit=1000%2C561&amp;quality=86&amp;strip=all 1000w" sizes="120px" alt="Will 'High School Musical 4' Ever Happen? The Cast Talks Reuniting for Another Movie" data-fallback-img="https://www.j-14.com/wp-content/uploads/2021/01/hsm4-pp.jpg?fit=1000%2C561&amp;quality=86&amp;strip=all" width="200" height="112"></div>									<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos"></use></svg></div>
											</span>
		
		<span class="link-related__content">
			<span class="link-related__title">

						Will 'High School Musical 4' Ever Happen? The Cast Talks Reuniting for Another Movie
			</span>

					</span>
	</a>
</div>

<h2>Where Was Nini During ‘HSMTMTS’ Season 3?</h2>
<p>In California! Olivia’s character was present during the first two episodes of the season when she traveled to California with her moms. However, that was the last fans saw of her until the third season finale where she made a surprise appearance at Camp Shallow Lake to see her fellow East High Wildcats perform <a href="https://www.j-14.com/tags/frozen/"><em>Frozen</em></a>.</p>
<p>“I had to hand out opening night cards. Tradition,” Nini told Miss Jenn (<a href="https://www.j-14.com/posts/high-school-musical-the-series-season-3-details-cast-more/"><strong>Kate Reinders</strong></a>), noting that her summer in California has been “easy” and “life-changing.”</p>
<figure class="wp-caption alignnone"><div class="ratio-based-placeholder" style="padding-bottom:80%;"><img class="alignnone size-large wp-image-270931" src="https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts02.jpeg?w=1024&#038;resize=1024%2C820" alt="Goodbye! How Olivia Rodrigo Left Her Role of Nini on 'High School Musical: The Musical: The Series'" width="1024" height="820" srcset="https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts02.jpeg?w=3000&amp;quality=86&amp;strip=all 3000w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts02.jpeg?w=1024&#038;resize=1024%2C820&amp;quality=86&amp;strip=all 1024w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts02.jpeg?w=2048&amp;quality=86&amp;strip=all 2048w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts02.jpeg?w=150&amp;quality=86&amp;strip=all 150w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts02.jpeg?w=300&amp;quality=86&amp;strip=all 300w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts02.jpeg?w=768&amp;quality=86&amp;strip=all 768w, https://www.j-14.com/wp-content/uploads/2022/09/Olivia-rodrigo-hsmtmts02.jpeg?w=2360&amp;quality=86&amp;strip=all 2360w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims="1"></div><figcaption class="wp-caption-text"><span class="credit">Disney/Anne Marie Fox</span></figcaption></figure><p>During their conversation, Nini expressed to Miss Jenn that while one of her moms wanted her to return to East High to finish out her senior year, she didn’t know if that’s what she wanted for herself. Miss Jenn told Nini that if they met up at the firepit after <em>Frozen</em>, that means she’s returning to East High and gave her the whole night to make her decision.</p>
<p>“Stay or go, you’re always a Wildcat,” Miss Jenn said.</p>
<div class="link-related link-related__with-thumb">
	<a href="https://www.j-14.com/posts/will-there-be-a-hsmtmts-season-4-cast-details-more/" target="_blank" data-track-category="Article Page" data-track-action="Tap Interstitial Link" data-track-label="https://www.j-14.com/posts/will-there-be-a-hsmtmts-season-4-cast-details-more/" class="link-related__link">
					<span class="link-related__image">
				<div style="padding-bottom:80%;" class="ratio-based-placeholder"><img src="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=200%2C160&amp;quality=86&amp;strip=all" data-srcset="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=200%2C160&amp;quality=86&amp;strip=all 200w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=300%2C240&amp;quality=86&amp;strip=all 300w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=400%2C320&amp;quality=86&amp;strip=all 400w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=600%2C480&amp;quality=86&amp;strip=all 600w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=800%2C640&amp;quality=86&amp;strip=all 800w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=1000%2C800&amp;quality=86&amp;strip=all 1000w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=1200%2C960&amp;quality=86&amp;strip=all 1200w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=1600%2C1280&amp;quality=86&amp;strip=all 1600w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=2400%2C1920&amp;quality=86&amp;strip=all 2400w" sizes="120px" alt="Goodbye! How Olivia Rodrigo Left Her Role of Nini on 'High School Musical: The Musical: The Series'" data-fallback-img="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=3000%2C2400&amp;quality=86&amp;strip=all" width="200" height="160"></div>									<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos"></use></svg></div>
											</span>
		
		<span class="link-related__content">
			<span class="link-related__title">

						'High School Musical: The Musical: The Series' Season 4 Is Coming and So Is 'High School Musical 4'!
			</span>

					</span>
	</a>
</div>

<h2>How Did Olivia Rodrigo Leave ‘HSMTMTS’?</h2>
<p>Naturally, Nini did not meet Miss Jenn at the firepit, meaning that she made the decision to move to California. Before she went, the teen met up with her bestie, Kourtney (<a href="https://www.j-14.com/posts/hsm-star-dara-renee-spills-behind-the-scene-secrets/"><strong>Dara Reneé</strong></a>), and wished her goodbye. Nini also left all the Wildcats their opening night cards — leaving Ricky’s (<a href="https://www.j-14.com/posts/joshua-bassetts-transformation-over-the-years-in-photos/"><strong>Joshua Bassett</strong></a>) for last. While she and Ricky didn’t get a chance to talk, Nini left him a lottery ticket with his card so he can celebrate his 18th birthday. This was also the final item on Ricky’s bucket list, which he was working to complete throughout the season.</p>
<p>“Miss Jenn, I didn’t want to say goodbye because goodbye means it’s over. So, I just want to say, thank you,” Nini’s card to Miss Jenn read. “After tonight’s performance, it’s clear there’s already so much talent at East. So, I’m gunna go west. Here’s to the start of something new. Forever your Wildcat, Nini.”</p>        
<p>Love <em>J-14</em>? Be sure to <a href="https://www.youtube.com/user/j14mag?sub_confirmation=1" target="_blank">subscribe to our YouTube channel</a> for fun, exclusive videos with your favorite stars.</p>
	        </div>

	<div id="sh-gal1" class="dfp-slot dfp-container sh-gal1 "></div>
    
	<div id="ds_default_anchor"></div>

    
    <div class="share-alt">
            </div>

    <div class="ds_mb mobile-only" id="ds_mb"></div>

	<div id="comments-wrapper"><div id="spotImCommentsDiv"
     data-spotim-module="recirculation"
     data-spot-id="sp_3FZzZ6QT"
     data-post-id="270930"
     data-post-url="https://www.j-14.com/?p=270930"
     data-post-tags="high school musical, olivia rodrigo">
</div></div>
    
	<div id="zergnet-widget-68224"></div>

    	<div class="post-related">
		
			<div class="post-related__item">
				<a class="post-related__image" href="https://www.j-14.com/posts/which-original-hsm-stars-have-guest-starred-in-hsmtmts/">
					<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&#038;resize=400%2C225&#038;quality=86&#038;strip=all" data-srcset="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=200%2C113&amp;quality=86&amp;strip=all 200w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=300%2C169&amp;quality=86&amp;strip=all 300w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=400%2C225&amp;quality=86&amp;strip=all 400w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=430%2C242&amp;quality=86&amp;strip=all 430w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=600%2C338&amp;quality=86&amp;strip=all 600w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=800%2C450&amp;quality=86&amp;strip=all 800w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=1000%2C563&amp;quality=86&amp;strip=all 1000w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=1600%2C900&amp;quality=86&amp;strip=all 1600w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?crop=0px%2C305px%2C3000px%2C1696px&amp;resize=2400%2C1350&amp;quality=86&amp;strip=all 2400w" sizes="(max-width: 767px) 100vw, (min-width: 768px) 500px" alt="Which Original &#039;High School Musical&#039; Stars Appeared in &#039;HSMTMTS&#039;? Corbin Bleu and More" data-fallback-img="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS-guest-stars0.jpg?fit=3000%2C2000&#038;quality=86&#038;strip=all" width="400" height="225"></div>				</a>

				<div class="post-related__title">
										<a href="https://www.j-14.com/posts/which-original-hsm-stars-have-guest-starred-in-hsmtmts/">Which Original 'High School Musical' Stars Appeared in 'HSMTMTS'? Photos</a>
				</div>
			</div>

		
			<div class="post-related__item">
				<a class="post-related__image" href="https://www.j-14.com/posts/will-there-be-a-hsmtmts-season-4-cast-details-more/">
					<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&#038;resize=400%2C225&#038;quality=86&#038;strip=all" data-srcset="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=200%2C113&amp;quality=86&amp;strip=all 200w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=300%2C169&amp;quality=86&amp;strip=all 300w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=400%2C225&amp;quality=86&amp;strip=all 400w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=430%2C242&amp;quality=86&amp;strip=all 430w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=600%2C338&amp;quality=86&amp;strip=all 600w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=800%2C450&amp;quality=86&amp;strip=all 800w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=1000%2C563&amp;quality=86&amp;strip=all 1000w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=1600%2C900&amp;quality=86&amp;strip=all 1600w, https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?crop=0px%2C182px%2C3000px%2C1696px&amp;resize=2400%2C1350&amp;quality=86&amp;strip=all 2400w" sizes="(max-width: 767px) 100vw, (min-width: 768px) 500px" alt="Goodbye! How Olivia Rodrigo Left Her Role of Nini on &#039;High School Musical: The Musical: The Series&#039;" data-fallback-img="https://www.j-14.com/wp-content/uploads/2022/09/HSMTMTS01.jpeg?fit=3000%2C2400&#038;quality=86&#038;strip=all" width="400" height="225"></div>				</a>

				<div class="post-related__title">
										<a href="https://www.j-14.com/posts/will-there-be-a-hsmtmts-season-4-cast-details-more/"><span class="post-flag">Wildcats, Everywhere </span>A New 'High School Musical' Movie Is Coming?! What We Know About 'HSMTMTS' Season 4</a>
				</div>
			</div>

		
			<div class="post-related__item">
				<a class="post-related__image" href="https://www.j-14.com/posts/high-school-musical-the-series-season-3-spoilers-bombshells/">
					<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&#038;resize=400%2C225&#038;quality=86&#038;strip=all" data-srcset="https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=200%2C113&amp;quality=86&amp;strip=all 200w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=300%2C169&amp;quality=86&amp;strip=all 300w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=400%2C225&amp;quality=86&amp;strip=all 400w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=430%2C242&amp;quality=86&amp;strip=all 430w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=600%2C338&amp;quality=86&amp;strip=all 600w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=800%2C450&amp;quality=86&amp;strip=all 800w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=1000%2C563&amp;quality=86&amp;strip=all 1000w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=1600%2C900&amp;quality=86&amp;strip=all 1600w, https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?crop=0px%2C0px%2C3000px%2C1696px&amp;resize=2400%2C1350&amp;quality=86&amp;strip=all 2400w" sizes="(max-width: 767px) 100vw, (min-width: 768px) 500px" alt="New Faces! Summer Romances! Bombshells From ‘High School Musical: The Musical: The Series’ Season 3" data-fallback-img="https://www.j-14.com/wp-content/uploads/2022/08/HSMTMTS01.jpeg?fit=3000%2C2000&#038;quality=86&#038;strip=all" width="400" height="225"></div>				</a>

				<div class="post-related__title">
										<a href="https://www.j-14.com/posts/high-school-musical-the-series-season-3-spoilers-bombshells/"><span class="post-flag">Breaking It Down </span>‘HSMTMTS' Season 3, Finale Bombshells: Nini Returns, Ricky and Gina Kiss</a>
				</div>
			</div>

		
			<div class="post-related__item">
				<a class="post-related__image" href="https://www.j-14.com/posts/hsmtmts-ricky-and-ginas-relationship-friendship-timeline/">
					<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&#038;resize=400%2C225&#038;quality=86&#038;strip=all" data-srcset="https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=200%2C113&amp;quality=86&amp;strip=all 200w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=300%2C169&amp;quality=86&amp;strip=all 300w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=400%2C225&amp;quality=86&amp;strip=all 400w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=430%2C242&amp;quality=86&amp;strip=all 430w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=600%2C338&amp;quality=86&amp;strip=all 600w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=800%2C450&amp;quality=86&amp;strip=all 800w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=1000%2C563&amp;quality=86&amp;strip=all 1000w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=1600%2C900&amp;quality=86&amp;strip=all 1600w, https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?crop=0px%2C0px%2C2400px%2C1357px&amp;resize=2400%2C1350&amp;quality=86&amp;strip=all 2400w" sizes="(max-width: 767px) 100vw, (min-width: 768px) 500px" alt="Will They or Won&#039;t They? Ricky and Gina&#039;s &#039;High School Musical: The Musical: The Series&#039; Relationship Timeline" data-fallback-img="https://www.j-14.com/wp-content/uploads/2022/08/Ricky-gina-timeline01.jpg?fit=2400%2C2400&#038;quality=86&#038;strip=all" width="400" height="225"></div>				</a>

				<div class="post-related__title">
										<a href="https://www.j-14.com/posts/hsmtmts-ricky-and-ginas-relationship-friendship-timeline/"><span class="post-flag">Breaking It Down </span>Will They or Won't They? Ricky and Gina's HSMTMTS Relationship Timeline</a>
				</div>
			</div>

					</div>

</div>

        <div class="l-grid__sidebar">
	<div id="rr1" class="dfp-slot dfp-container rr1 "></div>
	<div id="ds_rr_anchor"></div>

	<div id="rr2" class="dfp-slot dfp-container rr2 "></div>
	
	<div class="ad-container__sticky-wrapper sticky-bottom">
		<div class="ad-container">
			<div id="rr3" class="dfp-slot dfp-container rr3 "></div>		</div>
	</div>
</div>
    </div>

</div>


<footer class="site-footer">
	<div class="site-footer__inner">
		<div class="site-footer__left">
			<a href="https://www.j-14.com/" class="site-footer__logo" title="Home" rel="home">
				<span class="hidden-except-readers">J-14 logo</span>
				<svg class="logo">
					<use xlink:href="#logo-j14-footer"></use>
				</svg>
			</a>

			<div class="site-footer__left__inner">
				<div class="site-footer__social">
					<span class="site-footer__social__heading">Follow us!</span>
					<ul class="site-footer__social__list">
						<li>
							<a href="https://www.facebook.com/j14magazine" class="site-footer__social__link icon-facebook"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon"><use xlink:href="#icon-facebook"></use></svg></a>
						</li><li>
							<a href="https://twitter.com/J14Magazine" class="site-footer__social__link icon-twitter"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon"><use xlink:href="#icon-twitter"></use></svg></a>
						</li><li>
							<a href="https://www.instagram.com/j14magazine/" class="site-footer__social__link icon-instagram"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon"><use xlink:href="#icon-instagram"></use></svg></a>
						</li><li>
							<a href="https://www.pinterest.com/j14magazine/" class="site-footer__social__link icon-pinterest"> <span class="hidden-except-readers">Social icon pinterest</span><svg class="icon"><use xlink:href="#icon-pinterest"></use></svg></a>
						</li><li>
							<a href="http://j14magazine.tumblr.com/" class="site-footer__social__link icon-tumblr"> <span class="hidden-except-readers">Social icon tumblr</span><svg class="icon"><use xlink:href="#icon-tumblr"></use></svg></a>
						</li>					</ul>
				</div>

				
				<div class="site-footer__notification">
					<p class="site-footer__notification-text">J-14 has affiliate partnerships so we may receive compensation for some links to products and services.</p>
					<p class="site-footer__notification-text">J-14 is part of the A360 Media Entertainment Group.<br>Copyright © A360 Media LLC 2022. All Rights Reserved</p>
				</div>
			</div>

		</div>

		<div class="site-footer__right">
			<div class="site-footer__menu">
				<h3 class="site-footer__heading">J-14</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-1" class="site-footer__links__list"><li id="menu-item-148584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-148584"><a href="https://www.j-14.com/archives">Archives</a></li>
<li id="menu-item-98258" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98258"><a href="https://www.j-14.com/tags/selena-gomez-63/">Selena Gomez</a></li>
<li id="menu-item-98259" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98259"><a href="https://www.j-14.com/tags/one-direction-23/">One Direction</a></li>
<li id="menu-item-98260" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98260"><a href="https://www.j-14.com/tags/justin-bieber-104/">Justin Bieber</a></li>
<li id="menu-item-98261" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-98261"><a href="https://www.j-14.com/tags/disney-channel-156/">Disney Channel</a></li>
<li id="menu-item-98262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-98262"><a href="https://www.youtube.com/channel/UCt3AGx3We2PyyNIqCoiLnxw">You Tube Videos</a></li>
<li id="menu-item-121936" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-121936"><a href="https://www.j-14.com/accessibility-statement/">Accessibility Statement</a></li>
</ul></div>
									<!-- OneTrust Cookies Settings button start -->
					<a class="optanon-toggle-display" name="Manage Cookies">Manage Cookies</a>
					<!-- OneTrust Cookies Settings button end -->
							</div>

			<div class="site-footer__menu">
				<h3 class="site-footer__heading">A360 Media LLC</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-2" class="site-footer__links__list"><li id="menu-item-98263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-98263"><a href="https://a360media.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-98264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-98264"><a href="https://a360media.com/terms-and-conditions">Terms &#038; Conditions</a></li>
<li id="menu-item-98265" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98265"><a href="https://www.j-14.com/contact/">Contact Us</a></li>
<li id="menu-item-101394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101394"><a href="https://a360media.cloud.buysub.com/">Subscriber Service</a></li>
</ul></div>			</div>

			<div class="site-footer__cta">
				<div class="site-footer__cta__inner">
						<h3 class="site-footer__heading">Want more?</h3>
						<div class="textwidget custom-html-widget"><img src="https://www.j-14.com/wp-content/themes/ami-magazines/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.j-14.com/wp-content/uploads/2018/10/j14_cover-e1539589804523.jpg" alt="In This Issue of J-14" class="img-responsive img-cover" width="161" height="211"></div>						<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/JFT/JFT_print_digital_agecheck.jsp?cds_page_id=230176&#038;cds_mag_code=JFT%20">Subscribe!</a>
						<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/pubs/SR/JFT/JFT_Gifts_agecheck.jsp?cds_page_id=230179&#038;cds_mag_code=JFT">Give as a Gift</a>
						<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://a360media.cloud.buysub.com/">Subscriber Services</a>
				</div>
			</div>
		</div>
	</div>

</footer>
</div>
<div id="mb-sticky" class="dfp-slot dfp-container mb-sticky "></div><div id="teads" class="dfp-slot dfp-container teads "></div>	<style type="text/css" media="screen">
		@media screen and ( max-width: 782px ) {
			html {
				margin-top: 0px !important;
			}
			* html body {
				margin-top: 0px !important;
			}
			#wpadminbar {
				display: none;
			}
		}
	</style>
		<script>
		jQuery(document).ready(function ( $ ) {
			$('a[href^="http"]')
				.not('[href^="' + location.protocol + '//' + location.hostname + '"], [target="_self"]')
				.attr('target', '_blank');
		});
	</script>
	<script id='main-js-js-extra'>
var ajaxurl = "\/wp-admin\/admin-ajax.php";
var obj = {"templateUrl":"https:\/\/www.j-14.com\/wp-content\/themes\/ami-magazines"};
</script>
<script type="text/javascript" src="https://www.j-14.com/_static/??/wp-content/mu-plugins/jetpack-11.3/_inc/build/photon/photon.min.js,/wp-content/themes/ami-magazines/assets/build/js/main.js?m=1663082622j" ></script><script class='optanon-category-C0004' type='text/plain' src='https://static.adsafeprotected.com/vans-adapter-google-ima.js' id='ami-googleima-js'></script>
<script class='optanon-category-C0003' type='text/plain' src='https://www.j-14.com/wp-content/client-mu-plugins/shared/assets/js/dist/overlayRecircWidget.bundle.js?ver=6.0.2' id='overlay-recirc-widget-script-js'></script>
	<script>
		( function( $ ) {
			$( document ).ready( () => {
				if ( getCookie( 'mylo_token' ) !== undefined ) {
					$.ajax( {
						url: '/wp-json/mylo/v1/is-logged-in/'
					} ).done( ( ajaxResponse ) => {
						// const parsedResponse = JSON.parse( ajaxResponse );
						console.log( 'LOGIN', ajaxResponse );
						if ( 'undefined' !== typeof switchMyloControls ) {
							switchMyloControls( ajaxResponse );
						}

						$( '.header-mylo, .header-mylo__mobile' ).addClass( 'visible' );
					} );
				} else {
					$( '.header-mylo, .header-mylo__mobile' ).addClass( 'visible' );
				}
			} );
		} )( jQuery );
	</script>

	<template id="mylo-account-controls">
		<span class="header-mylo__label">Account</span>
		<div class="header-mylo__dropdown">
			<a class="header-mylo__account" href="https://www.mylo.id/account?client_id=25u4cv7suvrfjrjr22rf8jccq1&#038;logout_uri=https://www.j-14.com/auth/logout">
				<svg class="header-mylo__user-icon icon"><use xlink:href="#icon-user"></use></svg>
				<span>My Account</span>
			</a>
			<a class="header-mylo__sign-out" href="https://www.mylo.id/logout?client_id=25u4cv7suvrfjrjr22rf8jccq1&#038;logout_uri=https://www.j-14.com/auth/logout">
				<svg class="header-mylo__signout-icon icon"><use xlink:href="#icon-signout"></use></svg>
				<span>Sign Out</span>
			</a>
		</div>
	</template>
	<script src='https://stats.wp.com/e-202237.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.3.1',blog:'149160420',post:'270930',tz:'-4',srv:'www.j-14.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '149160420', '270930' ]);
</script>
</body>
</html>
